cd ripping with volumio primo doesn't work

I am trying to rip my CDs via the volumio primo. After putting in the Cd the titles etc are shown. But when I click the extract button the drive will only start for a second, then stop. That goes on forever and the whole system freezes. Could it be that I need a powered cd drive?
My drive has a y connection with usb 3 and usb c.
Would be grateful for any advice…

this sounds to me as a Power issue. The solution is connecting your CD drive to a powered USB hub. let me know

1 Like

Thank you,
I will try that, when I can get my hands on one. Will let you know if it worked.
Take care


Works perfectly with powered hub.
Thanks for your help.

Thank you for this hint, I’m facing with the same problem, so I connected my USB Samsung CD reader to a powered USB Hub. It seems it is improving since the RIP processing starts and a folder is created on the internal memory or on the USB pendrive. Unfortunately after some minutes the Rip process halts without any error messages and without creating any file.
Do you have any suggestion?

Glad to tell you I’ve solved the problem: I changed the USB hub power supply with a more powerful one and now the RIP process have been concluded successfully!