Can't turn on wireless network (x86)


I have used Etcher to write the latest x86 version of Volumio on a Samsung mSATA SSD, and then installed it in an OEM x86 NUC.

Volumio boots up into its GUI, but the wireless radio is not turned on by default. Every attempt to turn it on via the Networking GUI doesn’t stick, even though the Save dialog says everything is OK. Going to another page and then returning to the Networking page shows that Wireless is off.

This NUC works just fine with Daphile, booting either from the onboard mSATA drive, or via USB memory stick.

Help greatly appreciated.

Thank you.

Perhaps it is a driver issue. Do you know what the wifi chip is used in your device?

P.S. I’ve altered your post title to include x86 … you’re more likely to catch peoples’ attention with a bit more detail.

@chsims1 Thank you for your reply, and the title change.

The wireless chipset used in the NUC is the Intel Wireless-N 7260HMW BN.


Not sure what the latest dev version is now.

Edit: …

N.B. Disclaimer. Please note this is a dev version not an official release … try at your own risk.

Thanks for the two links. I first tried the dev release v2.459 that you suggested. It doesn’t load properly — failed to start the process Load Kernel Modules.

I then tried v2.419. The wifi hotspot starts, but then there is no option to connect Volumio to the local wifi network.

There is no option under ‘Network’ to turn wireless networking on?

Sorry, I wasn’t clear. In v2.419 there is the option to turn on wireless networking (and the hotspot therefore is also available). But no option to connect to the local wifi network.


I’ve got the exact same problem!

Just updated to latest version and this appeared!
Running on a RPI 3 - Wired works like a Charm, Wireless not working!