Can't Stream from SnapServer to SnapClient on Local Network

Hello everyone,

TLDR; I can’t get a RasPi 3B+, Volumio (v2.575), SnapCast v2.4.2 server to talk to a client of the same build.

I’m an old(er) hifi guy who’s been steadily working towards creating a multi-zone distributed audio system for my family. (okay, me too! :stuck_out_tongue: ) Having played a little w/ raspberry pi’s, I thought they’d be a great way to achieve my goal. And after playing with Volumio over the past few months, I think it’s the way to go moving forward. The sound is great! I can throw these things at Niles Audio OS6s, HD in-walls, and even my Monitor Audio Silver 9i’s (oldies but goodies) and I’m never disappointed in the detail I can achieve at a good background listening level. (Kudos to the HifiBerry and Volumio teams, your listeners really appreciate it.) Maybe more importantly, it works robustly and my wife can control it easily from anywhere in the house. Awesome! :smiley:

With that in mind, now I’m trying to scale this out to multiple zones playing synced audio. I picked up a few new Pi’s and spec’d them as below:

Raspberry Pi 3B+
HifiBerry Amp 2
Volumio (v2.575)
SnapCast (v2.4.2)

I bought one 3B+ to use as my SnapCast server. This unit doesn’t have an Amp hat, but does have a POE hat, as I’m hoping to power all of these zones using POE. I bought a second 3B+ w/ a HifiBerry AMP2 hat and power the unit w/ 12v POE splitter. Both units are plugged directly into ethernet.

Once I had Volumio and the plugin installed on the ‘server’ and the client (w/ AMP2 hat), I tried to get the two talking to each other. But this is where I’ve hit a wall (that I’ve been hitting for days).

I tried to follow the guide that I read here:

But this didn’t make sense to me, as the plugin is in Volumio’s plugin list (which is where I installed it from). So I installed it from within Volumio.

I also tried reading some other posts that I found by Googleing, like: … /issues/19

I’ve tried resetting the Volumio installs to factory defaults, uninstalling and reinstalling the OSs, and all kinds of playing around in the SnapCast plugin, but I still can’t get the client to play anything from the server.

What does ‘anything’ mean? So far I’ve tried to play two things. First I tried playing webradio on the server but I didn’t hear anything on the client. I then played the webradio station directly on the client to to confirm the station was live and it worked. When that test failed, I moved onto some NAS audio. Again, I tried playing this on the server with hopes of hearing output on the client, but no dice.

The caveat here is that I’m new to all of this so it’s probably my misunderstanding of how to use this system or a setting somewhere I’m missing. I’m fairly comfortable on PCs (can SSH into a Linux box, play around on command line, have written some code in my day) but I have to be missing something.

Help me Volumio-kenobi. You’re my only hope.

Server (Player Name: snapcastserver) SnapCast Settings:


Client Settings:


Okay. So I finally got this working though I’m not sure exactly why. In my original configuration, I had a standalone RPi/ Volumio (with no dac/ amp hat) unit acting as the server and another RPi/ Volumio (with a dac/ amp) as a client. This I could not get to work. This morning, I tried running one of my RPi/ Volumio (w/ hat) as the server and two other RPi/ Volumio units (w/ hats) as clients. Disco! And it sounds awesome. Will play with the configuration and Spotify this afternoon or tomorrow. Once this is all done, I think a tutorial might be in order…

Thanks for reading, all. See you soon.

Hi, I am struggling as well and I got sound but with a delay… Do you have the same or is it without delay?

Verstuurd vanaf mijn SM-G960F met Tapatalk

Hi there,

I think this is caused by the fact that snapcast was not yet compiled for Pi 3B+'s, I don’t have one yet, so I can’t really confirm this, but I believe the Pi3B+'s require recompilation of the binaries.

Kudo’s for the write up though, your problem is very clear to me. Thanks!

Update, if I don’t get ripped, I should have a 3B+ inbound now, bought one on the local marketplace :wink: So I should be able to test and confirm

That would be nice. Thanks!

Verstuurd vanaf mijn SM-G960F met Tapatalk

Hi all,

The B+ was delivered and I’ve been able to quickly test some setups. Both the server and client seem to work perfectly on the B+. I downloaded the latest image and installed snapcast from the store. I just pushed a patch for volspotconnect2 support, this is broken :wink:

I have two b+'s one with isolator plus kali reclocker feeding a tda1541 as snapcast server. The other with a hifiberry dac plus as snapcast client.
It is working fine but with a delay and only when I enable alsa output.

Verstuurd vanaf mijn SM-G960F met Tapatalk


If you enable alsa output, you’re not using the snapcast system, on the server you need both snapserver and snapclient for playback on that device. The client should use the reclocker as output and point to itself (default). The problem is then in the client-part of your server setup.

Thanks for the explanation! Will try it in coming days.

Verstuurd vanaf mijn SM-G960F met Tapatalk

I had some more succes and followed toppie tips buit still 1-2sec delay.
Alsa not used anymore.

Verstuurd vanaf mijn SM-G960F met Tapatalk

This is possibly a side effect of the Kali reclocker, which might cause a delay of 700ms and up. Does it also happen when you remove the Kali from the setup?

I will try that. Good idea!

Verstuurd vanaf mijn SM-G960F met Tapatalk