Can't seem to get mpod or mpad working properly

Hi. So I’ve set up volumio, mounted my NAS and connected it to my wifi network, and after much fiddling around, it works a treat. While I can control it from a web browser, I would like to be able to use mpod and mpad.

Problem is that I can’t get it to connect. I’ve gone through the forums and I understand that all I need to do is to enter in the ip address of the raspberry pi running volumio in the field at the top marked “Name”. And to leave everything else as it is.

When I do that, no information with my artists and albums comes up. Does anyone have any tips on what I can do to get it to work?

EDIT: Just tested GMPC on my windows machine and it connects to volumio beautifully.


No ideas? While I can get GMPC going I’m still having no joy with mpod or mpad. Surprises me because I thought that they’d connect in the same way.

Have you tried putting the rpi’s ip address in the “Server” field under the MPD section? I usually enter the IP address or “volumio.local.” in there. IP address works more consistently for me though. If that still doesn’t work, try killing mpod/mpad, then reopen and reenter the ip address.

I can’t imagine putting the ip address in the name field would do anything unless some magic happens on the back end. I use the “Name” field for giving mpd a more descriptive name like: “Man Cave Stereo.”

On a side note, previous installs of raspbian and manually installed mpd, mpod/mpad and even theremin on my mac was able to automatically find mpd installs on the network. I’m not sure what changed.

As you state Diet Shasta, enter the ip address in the serber field, voilá :slight_smile: