Can't mount my NAS with NFS

NAS:Synology DS920+
Volumio: Raspberry Pi 4B
NFS setting:

mounting setting:

Please, writing some words in your message is welcome… And some useful info such as Volumio version…
And if you need to show something in interface, set it in English, it is easier to help you.
Btw, have you tried to set in advanced options "vers=1.0’ ?
Or read that : Mounting an NFS Share - Volumio Documentation

System ver:

Have tried "vers=1.0’ it show this:

NFS setting:

mounting setting:


The NFS permissions on your NAS should be set to include the IP address of the Volumio device accessing the share, not that of the NAS itself.

changed the IP but still can’t mount

Please double check your mount path, or better stiil, if you can can get to the CLI on your device:

How to enable and use ssh.

post the result of:

sudo showmount -e

From the CLI again, try pinging your NAS from your Volumio device:


If that fails then you have a network problem.

it show like this

I think you should allow “non privileged” users. Now it reports “denied”

Your device cannot “see” the NAS over your home network. Can you use Web radio?

Yes I can

Sorry, but I’ve run out of ideas, you’ll have to do some problem solving of your own on your network, & possibly NAS NFS settings. Have a check on the Synology forums

Have been set like this but still can’t connect

Don’t bother, it is useless anyway.

I succeeded in making the connection with Synology DS115 but with a large collection it is very slow to use the play functions in Volumio. Better stream from PC or tablet or phone to Volumio.

Hi have you put your volumio on a static IP address and added that IP address to your NAS and have you added in the settings the “username and password” for access to your NAS?
And in your folder permissions for your shared folder, I have synolgy NAS and settings are “squash” = map root to guest.
“non privileged =denied and cross mount = denied”
And it looks like your IP address under “general” is for the wireless network and not static address of Volumio?

in case you are not sure about the IP address, you could enter 192.168.1.* instead to see if that makes a difference to get it at least working. “Non-privileged” and “Cross-mount” should indeed be left default (=denied).

My own experience:
With my Synology NAS, I changed to using CIFS for Volumio. There is not much to configure and Volumio does not reallly benefit from the speed advantage of NFS and the more efficient communication protocol it has.
It is also easier in case you want to access it from a Windows PC at times.
(Perhaps you do already)

The both system didn’t let me to use * in the IP adress

I give up because I can’t mount my NAS with NFS but I still can see my NAS in Media Servers:

Thank you everyone

The IP address of your Synology NAS is NOT

It is actually as seen on the screen grab where you are logging in to the Synology DSM Interface.

You need to make sure the IP address of your Synology NAS is fixed.