Can't get Synology NAs to mount

Hey guys,
I’m trying t get Volumio2 to mount my Synology Nas but can’t. I have read alot of documentation on the subject but nothing is working. I’ve had the NAS for along time and what I have working with the NAS now is the same procedure I am trying to use for Volumio2. Anybody have a step by step that they used to get things working? Thanks

Have a look here :

Yeah. That’s some of the documentation I have already read.

Decided to reboot the NAS and it mounted.Go figure.

Edit: NAS is mounted,but music is not being found when scanned.

Please give us a chance to help.
Is your platform a PI, Odroid, Cubox, x86?
Are you trying to connect with cifs or nfs?
I use a Synology NAS daily, so may be able to help.

Pi and using nfs.

Sent from my SCH-I535 using Tapatalk

Is shows 10gb where it shows that the nas is mounted, but that folder is not that big. Not sure what may be the problem.

Sent from my SCH-I535 using Tapatalk

Is it showing the size of the complete NAS?
I presume you had set ‘map all users to admin’ in the nfs privileges?

Yes,I mapped all users to admin. I found out that the 10gb is showing the total space I have used for all my folders on my NAS.
How do you have the folder setup? Mine is /volume1/music.I also tried volume1/music. I have my folders mapped to different letters,ex. my music is mapped to “Z”. Think this is causing an issue?

ok, i will setup a pi tomorrow and verify…


I got it fixed. I didn’t have admin permissions set to the music folder. All is good now.

:slight_smile: thanks for the feedback anyway.

why admin rights are needed ? i have normal smb/nfs permissions with readonly rights to the /music share and it works to be accessed by kodi etc
i never give opensource software rw access to my shares, so im using sort of dummy ro user for smb access.

trying to figure out how to proper enter the values in volumio2 gui, at the moment im stuck as it shows me a red_cross with a fake 526.00mb share , it seems it’s not mounted.

well often discussed in many threads i dig into them later,

@gkkpch i saw you were able to add your ds415 (i got 414) via NFS, may you please list me your settings in volumio .

the /music has proper permissions for years as it works for other access-clients, NFS is set to readonly for this share “/music” and from source home-network , so volumio should be able to access.

lets compare settings.

I also use a Pi B with a Synology NAS.

I’m using SMB to connect to it.
I have a share called “Music”, and the guest account is read only.
Volumio found the NAS immediately and scanned the Music folders without any problems. I didn’t have to give it read/write access.

as my permissions are set correctly and i can access the SMB folders with usual windows/mac it’s not a permission problem here. more a kind of syntax i think , perhaps someone is kind enough to post just a few screenshots.

from my opinion the add of a network share should be optical changed besides the delays during reloads are kind of strange.

using PiB with only latest volumio , i will try another SDcard on weekend and will post my settings later.


Hi beegee
I have the same setup (raspi b+) a synology NAS and the same problem.
With nfs share “moOde” works perfectly!
At this point, i will make some tests with old volumio “1.55” (in the past it has worked)

I solve it with volumio2

I have a “Raspberry Pi 1 Model B+” and a “i2s ES9023 Teradac DAC” like this, with a TCXO:

My files are in a Synology NAS Ds215J with DSM6 and folder “music” is shared also in nfs mode like this: … Share.html

Instead that is shown in the guide, in my volumio2 configuration the path parameter for me is “/volume1/music” but, i must reboot volumio first i see this folder is mounted.

I see also that web interface of volumio2 with my “Raspberry Pi 1 Model B+” is very slow and i have difficulty to change and memorize various parmeters so, i change a single value and reboot to verify that the new parameter is stored.

If i have time, but no too early, i will test volumio2 web interface with a “Raspberry Pi 2 Model B” that i at moment use with Openelec.

To conclude for audio use i prefer “Raspberry Pi 1 Model B+” that seems to be better and i have a one of this to use for something.


my shared folder is “music” and not “Music”