Can't flash volumio using balena etcher in catalina OSX

Hello, can someone please help me trouble shoot?

I’m trying to install Volumio on an SD card for my pi 3B+.

I just downloaded volumio-2.673-2019-12-01-pi.img and am using Etcher from Balena (1.5.52) on my mac (MacOS 10.15.1 (19B88)).

I formatted my 16Gb SD card to MS-DOS (FAT32).

I unzipped volumio, selected the image and the SD card.

When I “Flash!” I instantly get the message:

“Something went wrong. If it is a compressed image, please check that it is not corrupted.”

I downloaded volumio 3 times and always get the same message. I tried flashing from the zip and the img but still the same.

I’ve used this card in the past for other installs (N00b, Kodi, Retropie) and it has worked fine.

Does anyone have any ideas of anything else I can try?

EDIT: found a fix, see my reply below. I edited the title to better reflect the actual issue.

Figured out why and a fix.

Apparently there is issues with Balena Etcher in Catalina. Why am I not surprised!? Catalina has been a world of pain since I installed it.

To get around whatever is throwing out the error, launch Balena from terminal with the following command

sudo /Applications/

More info here -

Hi, i encountered same problem, i resolved it uninstalling, reistalling and updating the software…