Can't find the music library, and other issues

Hi –

I am running Volumio on an original Cubox, talking to a “Pico” usb dac and headphone amp combo. Right now, I am hardwired via Ethernet to my lan, and have some sample music files (FLAC) on a usb stick, formatted as fat32.

I can connect to the Cubox, connect to volumio.local, and listen to internet radio. There are some dropouts and/or scratch noises in the playback, but I haven’t played with buffer lengths and the various other options yet. I will say that Logitech Media Server running on my Windows 7 machine never has a dropout, talking to any of my Squeezebox players on the same network.

However, the bigger problem right now is that Volumio can’t find the music library on the usb stick. I suspect this is a permissions issue – I formatted and copied the flac files and folders on my Windows machine. I ran into this same issue (haven’t been able to fix it yet, either) trying to get a headless Logitech media server / player running on the Cubox.

Eventually, I want to add a portable eSata drive with about half a terabyte of flac files on it, along with a wifi dongle to the Cubox, and control it via an MPD client on IOS.

But first, I need some help getting it to find the music files! Also any suggestions re what I might try regarding dropouts/scratching.


Bob in San Francisco


Well, it “magically” started finding the flac files on usb stick…at least they show up when I hit “browse”>“usb”. Then, though, if I select one or more and add to playlist, or add to list and play, the previously playing web radio feed stops, but the flac music never starts.

At that point, sometimes, I need to reboot the cubox, which then reverts to playing whatever web radio station was selected previously.

I’m going to try a different MPD client program, to see if that changes anything. I am using the web client now.


1- start the cubox with USB drive in it
2- once on main screen, go to library and then update database
3- once finished, go to browse and hit ctrl +f5
4- let me know if this works!

OK. After doing that, it now show the 3 flac folders on the usb thumb drive, when I go to “browse”. However, as soon as I select one to play, the server crashes. This happens both with the web control panel and using the MPoD app on IOS. At that point, I have to unpower the Cubox, restart it, and then it will start back up playing the last internet radio station that was selected.

I am unable to play any flac files from the memory stick.

Also, I am getting dropouts and occasional scratch noises even when playing the radio stations.

Update: I tried it again, just to be sure, same result. When using the Web control panel, it just freezes, unable to do anything further. When using MPoD, it disconnects from the server as soon as one of the usb files is selected. In either case, only way to continue is power off/power on the cubox.

please try that with SSH

apt-get remove cifs-utils

if you don’t need Nas support

OK. OS not crashing anymore, and some of the web main menu functions still work. However, music play still stops as soon as anything from the browse>usb list is selected. SSH session remains connected. Play list editor on web version does not seem to work at all, always shows the same two songs (from some radio station? not the one actually playing, in any case).

With MPoD, it’s not disconnecting anymore, loads album song list, artwork, etc. However, when you try to play one of the songs, nothing happens.

In either case (web panel or MPoD) as soon as a song on usb is selected, music play immediately stops.

That’s really weird… I’ll try to replicate that…
Try to hit ctrl+f5 again…

Nope, still does the same thing. I did see that if I select a song, it gives the message “added to playlist”, but the music still stops, and if I go to the playlist, it doesn’t show anything except the two persistent songs from who knows where.

I do have another question – my intent with this project is a portable music system for our camper. My FLAC library has about 10,000 tracks in 1000 folders. I want to copy these to a portable e-Sata drive, connect that to the Cubox e_Sata port, add a wifi dongle to the then-open usb port, and control the whole thing via an MPD client from IOS devices.

Any idea how long it would take Volumio on a Cubox to index the e-Sata drive initially (and is e-Sata even supported by Volumio)? Once indexed, does it store the index locally, or would it have to re-index the library every time I start it up?



I know you’ve been busy with the new pi release, but did you get a chance to check on this Cubox issue?

BTW, is there a way to toss contributions for the project in your direction? I am sure others besides myself would be happy to throw some cash your way to help with Volumio.

I found the “donate” tab on the main page. Little Christmas present coming your way. This is a great project – please keep it up! :smiley:

Any status on the Cubox issues I posted?