Can't find my WLAN

Hello everybody,

i’ve got a RPI3 with Volumio 2 installed and the Hifiberry Amp. This I have connected via LAN on my “Kabel Deutschland Router”.
With this “Kabel Deutschland Router” I don’t have WLAN. Therefor I have an old Fritzbox connected via LAN to the “Kabel Deutschland Router”.
In this way I’ve WLAN in my flat.
Unfortunately I can’t connect via Smartphone to volumio because this are 2 different Networks (“Kabel Deutschland Router” and Fritzbox). I know there is a way with volumio Hotspot but then I Change my WLAN all the time and thats not practicable.
Now I connected my Notebook via LAN to the “Kabel Deutschland Router” and enter volumio.local. There I can’t find my WLAN but all other’s arround me. Then I tried to connect it manually by typing the ssid and Password but nothing happend.

I hope you can help me.
Thanks in advance.


Can you connect to the Volumio UI with your laptop connected to the router? If you can then go to network setting and add your Fritz wireless network.

I don’t understand how you have two wireless networks here if the router does not have wifi?? Does your phone actually show both of these networks? If you managed to add the Fritz network as suggested above, then you should then be able to see Volumio after joining the Fritz network on your phone.

Note that you might not be able to connect using the IP address volumio.local, depending on your particular hardware. In this case you will need to find the actual IP address assigned by your router to Volumio.

No I haven’t two WLAN Networks. I have one
LAN Network: “Kabel Deutschland Router” that gets the Signal from the Provider (via cable)
WLAN Network: Fritzbox that gets the Internet Signal from the “Kabel Deutschland Router”

I am not able to find the WLAN of Fritzbox witihn volumio!
Thats the actual Problem.

I think that we are talking at cross purposes here. The Fritz box will be on the same network as your router.

With your laptop and Volumio device connected to the router, can you connect to Volumio? If so, set up your wireless connection to the Fritz box. Then try via your phone to connect to Volumio

Thats what I already tried.

But as I said if I with volumio search for WLAN, I can’t find my Fritzbox. I only can find WLANs of my neighbourhood.

So, is your Fritz box actually working? Can you connect to the internet via your phone and the Fritz network?

Yes it’s working and I can connect with all other devices to the Fritzbox and have Internet Connection. Furthermore the Fritzboxs WLAN isn’t hidden.

Can you please try connecting to Volumio with your laptop connected to your router…just to make sure it is working.

You meant Raspberry Pi with Volumio installed is connected via LAN to the “Kabel Deutschland Router” and Notebook also connected to this “Kabel Deutschland Router”?

That works.

Ok, so now with your laptop and Volumio device connected, can you see the Fritzbox wifi network in the Volumio UI network settings?

I’m really sorry if this seems to be very convoluted, but it’s difficult to sort stuff remotely.

No I don’t see it.

OK, so your installation of Volumio is working fine, but it is unable to see a working network provided by your Fritzbox. It has been reported elsewhere on these forums that the internal wifi provided by the RPi3 is a bit “erratic,” but I am surprised that it fails totally (I have one which works fine). Do you have a usb wifi adapter that you could try?

Yes i have. I will try it in the evening.

Sorry for the delay buut finally I test it but it doesn’t work too.
It finds several wlan Networks in the surrounding but not mine.
I double checked if my wlan is hidden or only accept known devices (mac adress) or something but also negative.

I recently also had issues in setting up Wifi (new Pi user here). The Raspian distro that came with my Pi 3 kit had no problem to get working with my Wifi but the Volumio distro is another story. I found a couple things when solving my issue:

Pi 3 doesn’t support 5GHz Wifi: … 6&t=138166

I had to make some changes to a couple files to get it working with native Wifi on RPi 3 (in my case, cable company supplied Wifi equipment uses WPA2 security at 2.4GHz):

edit /etc/network/interfaces with the following for wlan:

allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

edit /etc/wpa_supplicant/wpa_supplicant.conf


Do you need two subnets? Unless, the Fritzbox please assign a fixed IP, from the LAN subnet.
Reduce the DHCP range of the Kabel Deutschland router by the fixed IP addresses.
DHCP in the fritzbox switch off. Then the WLan in the Fritzbox was also found by volumio.