Can't connect to SMB/cifs network share

Hello, trying to get up and running with volumio, but I can’t connect to my network share.
My NAS is Synology DS1515+
I am using SMB file sharing.
I have no problem connecting to my network share using my Windows 10 computer, my Arch Linux laptop, or using runeaudio on my Raspberry Pi 3B (not the brand new 3B+, but the older RPi 3B). So I don’t think it’s any permission issue on the NAS. Now trying to switch from runeaudio to volumio, using the same Raspberry Pi 3B

Here are the settings I’m using:

I tried searching these forums, and all the solutions that I’ve found suggest to use NFS instead of cifs. But I’d prefer to just continue using cifs. Is this a known issue with volumio? Am I doing something wrong?

Thanks in advance for any help.

What version of ciffs protocol are you on?
Add vers=2.0 or vers=1.0 into the options field and check if that works for you!



I hadn’t checked my version of cifs, whatever the default was for Synology.

This is what my NAS shows

I guess that means that I’m running both SMB1 and SMB2?

In any case, I added “vers=2.0” to the options, and it worked.

Thank you very much for the quick help! Much appreciated!

Was in a similar situation a few weeks back, but a little irked cause my working setup didn’t work anymore.
After some troubleshooting, and poking around the files from ssh, I found the easy GUI solution in the github issue.

Anyway, glad to help!

I converted my NAS share from NFS to SMB and for that use the CIFS file share type setting in Volumio.
Adding vers=2.0 was the thing that did the trick for me too. Thanks!

Glad I found this. Ran into the same problem. Previously I had used vers=1.0 but it wasn’t working with latest version of Volumio. vers=2.0 did the trick!