Can't boot kernel - Cubox i4 Pro - volumio 1.5 image

Hi, I really would like to try volumio but it seems I must be such a noob and probably must be doing something wrong!

What I did was following instructions in getting started :

a. Downloaded image for cubox i;
b. Through win32disk imager did one image with success status, no boot;
c. Through win32disk imager did one image with other SDcard with success status also, no boot;
d. Downloaded 1.5 cubox i image again and tried win32diskimager again to no success;
d. Through a Ubuntu Linux, specifically formated the SD card to erase all partitions and then flashed manually a card with success but no boot also;

:confused: Pretty frustrating. I must be repeating my misktakes! :exclamation:

The boot always stops at “Booting kernel”

The front led lights on boot as well as spdif port. The later shuts down within a second or two.

The output from the boot is the following:

U-Boot SPL 2013.10-rc4-ge4bc4c3 (Oct 24 2014 - 18:34:26)
Boot Device: SD1
spl: error reading image u-boot.img, err - -1
Load image from RAW…

U-Boot 2013.10-rc4-ge4bc4c3 (Oct 24 2014 - 18:34:26)

CPU: Freescale i.MX6Q rev1.2 at 792 MHz
Reset cause: POR
Board: MX6-CuBox-i
*** Warning - bad CRC, using default environment

In: serial
Out: vga
Err: vga
(Re)start USB…
scanning bus 0 for devices… 1 USB Device(s) found
scanning usb for storage devices… 0 Storage Device(s) found
scanning usb for ethernet devices… 0 Ethernet Device(s) found
Hit any key to stop autoboot: 0
mmc0 is current device
** File not found /boot.scr **
** File not found /uEnv.txt **
** File not found /zImage **
** File not found /uImage **
** File not found /boot/boot.scr **
214 bytes read in 94 ms (2 KiB/s)
Importing environment from mmc0 …
5937696 bytes read in 359 ms (15.8 MiB/s)
Booting from mmc …
33568 bytes read in 86 ms (380.9 KiB/s)
Loaded imx6q-cubox-i.dtb
Booting zImage
Kernel image @ 0x10800000 [ 0x000000 - 0x5a9a20 ]

Flattened Device Tree blob at 18000000

Booting using the fdt blob at 0x18000000
Using Device Tree in place at 18000000, end 1800b31f

Starting kernel …

Let me just add that I was abble to flash a card for other distribution (mubox) and it worked perfectly on the exact same cubox!

Can somebody please help?


  1. Make sure to format the microSD card using fat32. Use

  2. Confirm the correct version of Volumio was downloaded. Here’s where to get it in case you had it wrong:

I also have a Cubox I4 Pro but didn’t have any problems booting. The only problem I have is there is no sound coming out while I was able to run Voyage Mubox as well without any issues.

Hi TopQuark,
Thank you for your feedback but in fact I doubled check and redownloaded to make sure that was not the mistake.

As for SD formatter thank you and i tried it but the behavior was the same. But of course this wasn’t the problem. In fact the problem was I was booting connected through console and during boot console get’s deactivated!!! :astonished: So what kind of linux system doesn’t have a console :unamused: ?!

So only when I connected through HDMI and a usb keyboard I was able to see what was happening. :unamused: So there was no problem with flashing any image from the very beginning.

I don’t know it there’s info anywhere stating this but if it’s not it should otherwise it my happen to somebody else.

On one hand I understand the volumio concept of flashing an image plugging in and that’s it but what if there’s something wrong with your router and you dont’ get an IP Address?! You can’t ssh because there’s no IP and you get stuck without any info, or am I seeing things wrong?

Well, on the positive side, fun is about to begin :mrgreen: