Can't adjust volume in GUI or via alsamixer

Volumio Audiophile Music Player for PC (X86/X64)
VERSION: 0.976
RELEASE DATE: 28-07-2016

Adjustments to the volume won’t take effect. I’ve tried to adjust the volume through the GUI directly on the device and through alsamixer (open alsamixer and adjust the volume for PCM). In either case the numbers change, but the volume remains at 100%. :exclamation:
I am glad my speakers can handle it otherwise I might would have blown them. :exclamation:

I’ve previously used Voyage MPD, which is also based on Debian 8.x, on the same hardware (incl. DAC) without any issues. Would love to give this distro a try, but this is a show stopper. Any suggestions?



Try to change the mixer name, then hit save. How many options available do you have?

Through the GUI the only option available is PCM. In alsamixer I see Headphones, Master, etc. Adjusting the levels on any of those has no effect on the volume.

Same problem here with Raspberry Pi A + Audiophonics Sabre DAC. No effect while changing something via GUI.
No mixer is avaible to choose.

Some dac are not capable of hardware mixer. It’s because you haven’t got a selectable mixer. The way is to generate a software mixer “softvol”.
This is not yet implemented in Volumio2.
You can try to do it by creating a /etc/asound.conf file that contains something like you can find here

Could you please paste here the content of alsamixer ( use f6 to get to your DAC)

Here you go:

DAC is a Topping D20. I’ll try what you suggested and report back.
Do you have a list of supported DACs that work plug’n’play?

Putting it to max doesn’t change anything, right?
To me it seems a DAC’s problem actually…

I don’t dare to set PCM to max. This is an expensive audiophile setup in my listening room. :wink:
Unless you suggest that setting PCM to max has the an reverse effect on volume levels which seems counterintuitive to me?
I have another setup for headphone listening that uses a SMSL M8 DAC. On that particular setup volume settings work as expected. Although I did notice that when Playback options > Volume options > Default Startup Volume is set to for example 30, after reboot the GUI still shows the volume level at 100. Is this by design?
Maybe you can explain how Default Startup Volume, Max Volume Level and the volume control in the GUI and alsamixer PCM settings co-relate?
I would also appreciate it, if someone on the dev team could help myself and users like _flori with DACs that don’t support hardware mixing capabilities out of the box. The Topping D20 is a very popular low-end DAC option that performs competitively with devices at a much higher price-point.
I’ve tried balbuze suggestion, but I am not familiar enough with configuring alsamixer options at the CLI and I wasn’t able to create a ‘softvol’ mixer option. I can’t be the only one in this boat?
Myself and I am sure others would really appreciate your help.



I was suggesting this to see if alsa was affecting sound at all…
And yes, soft volume is very requested so I will develop it after all current bugs are fixed

Hi, i have the same problem (with the same audiophonics dac and rpi 2) on Volumio 2 (0.979 version).
The soft volume works like a charm in Volumio 1.55.
Anyway… Volumio 2 is GREAT, “grande figata” and softvolume would be the icing on the cake…

I’m having the same issue with Odroid C1 and HiFi Shield Volumio2 v0.976.

Just update to 2.001 :wink:

Hey… first off, thank you for all the improvements that came with the latest release. I’ve been using it since it’s release on two devices and found performance and stability to be improved. And NIC works now out of the box … yeah!
But… software volume is still not working for me. Are there some additional steps I need to take? By not working, I mean there’s no option to select it under playback options. Maybe I am just missing something here?


Never mind … I see there’s already a thread going for this.
Check out Bug Report thread here