Cannot mount NAS

I had volumio-2.513-2018-12-07-pi.img running on a pi for some time, but it appeared to have stopped working, a problem I have since deduced was a network cable issue.
But I did a clean install of Volumio-3.175-2021-12-13-pi but I am unable to mount the music from my NAS. I retried the older version and that had exactly the same issue.
I think I recall not finding it easy when I installed the original version a few years ago.
I can view my media library via Windows explorer and shows as located here:-


I wish to point Volumio at this directory which contains a number of directories each with their own set of MP3s.
The Add New Drive offers me 3 boxes, the first being a label, which I believe to be a name for reference purposes only.
In the second, NAS box, I add either NAS_NAME or, it makes no difference which.
In the Path box I add MyBook\Media\MP3
I select nfs.
On save I get an orange box at the top right which doesn’t stay there long enough to read its contents. The words error and failed to mount can be seen.
I have tried all sorts of variation of \ and / to no avail. Following the save, the display shows the path as entered above with a red x under Mounted.
What am I doing wrong?

The second is simply the IP address of your NAS (
The third is the one that causes many problems, because it is not always obvious how the share name is broadcast. Are you sure that you used NFS previously? If not, add the path as “MyBook/Media/MP3”, add username & password, and leave the default cifs setting. If that doesn’t work then, add “vers=1.0” in the advanced options.

Thanks for the hints, I have tries all the combinations and permutations of what you suggest.
I have also managed to capture the error messages, shown below:-

Error when adding network drive
(2): No such file or directory Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Error when adding network drive
exec error Error: Command failed: /usr/bin/sudo /bin/mount -t nfs -o ro,soft,noauto ‘’ ‘/mnt/NAS/Kirkstall’ mount.nfs: Connection timed out

Error when adding network drive
exec error Error: Command failed: /usr/bin/sudo /bin/mount -t nfs -o ro,soft,noauto ‘KIRKSTALL:/MyBook/Media/MP3’ ‘/mnt/NAS/Kirkstall’ mount.nfs: Connection timed out

Error when adding network drive
exec error Error: Command failed: /usr/bin/sudo /bin/mount -t nfs -o ro,soft,noauto,‘vers=1.0’ ‘KIRKSTALL:MyBook/Media/MP3’ ‘/mnt/NAS/Kirkstall’ mount.nfs: mount system call failed

From the first error it is clearly not happy with cifs.
Using either name or IP we get a time out, this is the same with and without a user and pasword.
I don’t believe it requires a password, if it does, I have the user and password for the pi that runs the NAS, but I have never had a problem connecting to it from any other device.
There is one difference with user/password, there is a size shown, which is showing 530.09 MB but becomes NaN with user/password.
As soon as I add vers=1.0 the system command fails.

If it’s any consolation I too have had such issues previously there are two versions to try the one you used also vers=2.0, I tried these in all combo’s before and they failed but oddly I reverted to just entering my name of NAS and IP address left it as cifs no version entered set my user name & password for NAS and hay ho it worked so keep trying you will get it and the issue with mounting the NAS and correctly loading it is working fine.

Thanks for that, I guess I will just have to keep trying.
I won’t have any spare time for a couple of days, but one thought is to see if there is some way to SSH into the system and modify the file that holds the path directly.
It would have been good if there was a mechanism to browse, all the evidence suggests that it can see the NAS, but I am unable to find a form to enter the path into the boxes that will crate a valid path internally.

Please try nfs or cifs one at a time, otherwise it is impossible to follow what you are doing. Trying all permutations is obviously not working.

If you have ssh access to the device, then you can try the command “sudo smbclient -L” to see what cifs shares can be seen." Similarly you can try “sudo showmount -e” to see what nfs shares are available.

Each of the error reports above was created by adding a drive with those parameters. That drive was deleted and a new drive added with a different set of parameters. By performing these one at a time, I went through all the permutations.
Trying the above commands gave these results:-

sudo smbclient -L
do_connect: Connection to failed (Error NT_STATUS_HOST_UNREACHABLE)

sudo showmount -e
clnt_create: RPC: Unable to receive

Does that tell us anything that might help.

What do you see on your NAS as the name of the shared folder (not what Windows says it sees)?

Can you just try pinging your NAS from the RPi, just to make sure that there is actually a network connection?


Can you also try to manually mount the NAS with:

sudo mount -t cifs // /mnt/NAS/Kirkstall


sudo mount -t cifs // /mnt/NAS/Kirkstall

I’m now totally confused.
ping by IP address gets no response, by name goes onto the internet from Volumio, but gets a local response from within a windows machine.

volumio@volumio:~$ ping
PING ( 56(84) bytes of data.
From icmp_seq=1 Destination Host Unreachable

volumio@volumio:~$ ping kirkstall
PING kirkstall ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=56 time=35.0 ms

from Windows
ping kirkstall
Pinging kirkstall.local [2600:1700:9260:5930:9e0e:6a08:40b0:d7b6] with 32 bytes of data:
Reply from 2600:1700:9260:5930:9e0e:6a08:40b0:d7b6: time=1ms

I had this problem too. My music server is an NFS server, running on an instance of Linux (Ubuntu Server) on a tiny computer, so the solution for me won’t be the solution for everyone.

I solved the problem by:

  1. On the music server, adding the IP address of the Volumio instance to the file /etc/exports;
  2. On the music server, running the command export fs -a, which updates /var/lib/nfs/etab (this file is looked up by the server when you add a network drive on Volumio);
  3. On the music server, restarting the NFS server by running the command service nfs-kernel-server restart;
  4. On the Volumio instance, adding the relevant network drive.