Cannot get Airplay to work

First, my apologies as it definitely must be something I am doing wrong, but I just am not able to get Airplay output from my iPhone 13 to my VolumIO 3 running on Raspberry pi 3b+ system. The web interface shows that Airplay is activated but I get no audio at all. If I switch back to, say Pandora of Web Radio everything works fine so I am sure it is something with the way I have set up my system. Here is what I have:
Output from System Information Plugin
System Information

OS info

Version of Volumio: 3.233
Hostname: musicbox
Kernel: 5.10.92-v7+
Governor: performance
Uptime: 0 days, 3 Hrs, 31 Minutes, 41 Seconds

Audio info

Hw audio configured: Headphones
Mixer type: Hardware
Number of channels: 8
Supported sample rate: 44100 48000 88200 96000 176400 192000

Board info

Manufacturer: Raspberry Pi Foundation
Model: Raspberry Pi 3 Model B Plus Rev 1.3
Version: a020d3
Firmware Version: Jan 20 2022 13:58:22 - bd88f66f8952d34e4e0613a85c7a6d3da49e13e2

CPU info

Brand: BCM2837
Speed: 1.4Ghz
Number of cores: 4
Physical cores: 4
Average load: 8%
Temperature: 56°C

Memory info

Memory: 990016 Ko
Free: 394516 Ko
Used: 595500 Ko

Storage info

INTERNAL storage - Size: 12481Mo
Used: 1236Mo
Available for storage: 10588Mo (85%) 

Web interface screen

As indicated in the System Info the headphone output from my pi is active and is plugged in directly to my Vizio Soundbar. Everything works if I turn off Airplay.
Link to debug log report:

Appreciate any insights.


There is one very big issue in the logs:

Mar 13 16:15:09 musicbox kernel: Under-voltage detected! (0x00050005)
Mar 13 16:15:15 musicbox kernel: Voltage normalised (0x00000000)
Mar 13 16:18:18 musicbox kernel: rpi_firmware_get_throttled: 2 callbacks suppressed
Mar 13 16:18:18 musicbox kernel: Under-voltage detected! (0x00050005)

Your power supply is failing to supply enough power to your Pi. Anything could be going wrong from here.

The next thing I would say is that Airplay comes through at very low volume compared to other sources, and it has multiple potential volume controls. Make sure your phone (or tablet) has volume turned up to full when you are playing from it, then make sure Volumio’s volume is set high, then set the volume on your soundbar appropriately.

Ihave the same advice as Timothy. I thought Airplay was not working at first but then realised that I have to turn my Mac volume to 100% before I could hear anything at all.

Thanks to you and timothyjward - that’s what it was!! cranking up the volume on my phone and on volumio worked and now I can hear the Airplay output. Is this the way it is going to be, as it might blast my soundbar when/if I switch back to the other outputs and dont remember to reset the volume :roll_eyes:?

Regarding the power supply under-voltage issue - it keeps saying that and reverts back to normal (as the log shows) so I guess it is marginally under powered as it works fine all day. Might get one of those “special” power supplies sometime.

Thanks again :+1:t4: :+1:t4: :+1:t4:

It’s at least partly the fault of the phone, which we can’t fix, but it is something I want to work out how to improve. I’m sure that there’s an attenuation somewhere in shairport that we can disable.

When you say it is “partly the fault of the phone”, do I understand that to mean that the iPhone automatically reduces the output when it connects to the Airplay client?

Appreciate your quick responses, and hope you find the source of the attenuation.

When you say it is “partly the fault of the phone ”, do I understand that to mean that the iPhone automatically reduces the output when it connects to the Airplay client?

Yes, this can happen with headphones too. The phone is trying to avoid damaging your ears.