Cannot find network drive

Volumio Information

Volumio Version: 2.861
Hardware: Pi 3B ( I think. Might be plus)
DAC: USB Dragonfly on powered hub

This setup has been working fine for years. Library is on a USB drive connected to the router. Yesterday, I forgot I was rescanning the library and I unmounted the drive from the router. When I remounted it the Volumio could no longer scan the drive. I deleted the drive, but when I scan for network drives, I get “No Network Drives Found” The user interface shows up on the network, so I assume it’s connecting ok.

Three other Volumios with basically the same setup seem to still work fine on the same network. They find new files when I update. I have not tried deleted and reconnecting to the drive.

I ended up scraping the SD card and reinstalled from a new download. Didn’t fix it. Now I’m really scratching my head.

Any ideas?


Today I put some music on a thumb drive and plugged it into the USB hub. It scanned automatically, no problem. It still cannot find the network drive.

I think I’ve got it working again. It’s scanning now. I’ll know for sure in the morning. I found another post that referenced a similar problem. They had to delete the sharing account in the router and create a new one. Then it took me a while to figure out the IP address of the router (which isn’t really an ip address).

I’ve never figured out how to set up a drive on this router so the volumios can access it and other computers on the network can access it as well. It would especially after this problem, it would be nice if I could just copy new music directly to it instead of having to unmount it and plug it into the ripping computer to move files. Maybe it’s time to invest in a real NAS.

Regardless, they’re all scanning, so good for now. I hope.

Can you add the mount back by supplying IP address, path etc?

I do not think so, but it is hard to say since I was changing settings on the router too and maybe just got in my own way. At least some of the times I tried to do that, instead of terabytes, I occasionally mounted 30 MB.

But as I said above, deleting and recreating the sharing account on the router allowed me to reaccess it.