Cannot connect to Volumio

Hi everybody,

I installed Volumio 1.55 on a Cubieboard 3 (Cubietruck) today.
I plugged the Cubie on my network with the card in and switched it on. I then tried to:

  1. connect to volumio.local/ and it did not work;
  2. Connect to the device IP and it did not work either;
  3. SSH the device and it did not work;
  4. Check my router and found the device on the network map, also check my port routing and nothing special there;
  5. Ping the device IP and it actually worked.

Can anyone tell me please what I am missing? I basically see the device on my network, I can ping it but that’s it. It is odd.

Thanks in advance.

That’s really odd… Do you know if your router has some kind of network restrictions or QoS policies?


I am not aware of any of this. I Used my Cubie with Linux (Lubuntu) as well as a Raspberry Pi with Recalbox (distribution for game emulation) and it worked well.
I just cannot understand how the Cubie can be on my network and yet inaccessible. Shall I try to enable DMZ on my router?

Shameless bump!

I found why it is not working but cannot fix it: I currently have a Lubuntu installed on the NAND and it seems the cubie won’t boot from the SD but on the NAND instead.
Now my issue is the following: how can I make the cubie boot on the SD? In the alternative, how do I wipe the NAND?