Cannot browse to internal SD card from windows [SOLVED]

Volumio Information

Volumio Version:2.861
Hardware: pi4b

Hi, new user wanting to load some tunes to the internal sd over the network, webui works fine, can ping the ip address without issues, cant navigate via file explorer, been reading for the last two days and just hit a brick wall

also roon cannot find it as a core either even though plugin enabled and im thinking this may be related

I’ve disabled firewall, made sure everything needed is enabled from a windows networking angle but still no closer to a solution

thanks in advance

Can you see your Volumio device in Windows at all? Under network? Do you have file sharing enabled? The share name should be “Internal Storage”.

Hi, thanks for the reply. I can see the player as a media player in my network, network discovery is on and file and print sharing enabled, password protected sharing disabled

sorted it, had to enable unauthorised guest access as the shared folder is public


set allowinsecureguestauth to 1

Is this really a secure choice? Is there instead a way to set this Internal Storage up more securely such that Windows can see it? Right at this instance, Windows doesn’t even list Volumio as a member of the network like it does the other 3 PCs in my house. I do see the UPNP entry for Volumio, but that just takes me to the main web UI.

Basically, while the Volumio device (RPi 4) can access any Windows share I desire to set up, the reverse doesn’t seem to be true.

Any further assistance would be greatly appreciated. No, I’m not terribly familiar with Linux (yet).