Cannot "Browse" the songs on the TF card


I have two Volumio setup in both my home office & bed room.
I use NAS which works fine.

As I am using 64G TF cards so I want to use the “INTERNAL” to store the songs instead of going via the wifi @bedroom.
However, I cannot Browse the INTERNAL because only the NAS icon shows up.
Below is what I see under MNT
volumio@volumio-bedroom:/mnt/INTERNAL$ dir

For troubleshooting, I tried the same on my home office Volumio.
This one I can Browse NAS, INTERNAL & USB but INTERNAL is empty.

I am using the latest stable version on both devices.

Are you sure that there is anything on the card? Can you list the songs under /mnt/INTERNAL?

I can see the songs using \ip\Interntal Storage from win10 machine

It worked before on older version of Volumio but this one is a fresh install.

I found out what is the prob but dont know how to fix it.

It beleived to be an UNICODE prob. If I copied songs with all English characters, I can see the directory & songs under \mnt & samba but however I still can’t see on the Volumio app or via browser.