Can’t get Volumio to work with RPi0W

I have tried flashing the sd card few times now and it gives me the same error message… and there is no Wi-fi HOTSPOT or otherwise (generated by Volumio as in the setup guide). Volumio won’t go past this screen and green light not blinking but is on constant…I thought it was fixed by now for the RPi0W with the current version of volumio…

Can anyone please help, I must be doing something wrong here or missing a step…
Does Volumio work with Raspberry Pi ZERO W with its existing wifi config or do I need a Ethernet to USB converter thingy to connect RPi0W and Volumio to my Network?
Volumio Version:2.861

Hi - I’m sorry to hear that you’re having a problem with getting started on Volumio.
The issue you’re showing looks quite a lot like an SD card error. How big is the SD card that you’re using and have you tried flashing/booting with a different SD card?
It would also be good to know whether you’re able to flash the current SD card with Raspberry Pi OS and boot normally.

I agree with Tim: looks like a bad SD Card to me…