Can see hotspot but not connect

I’m very new so I really hate opening a thread, but I just can’t find anything that addresses exactly whats going on.

I have volumio installed fine, it creates a hotspot fine, it accepts my password fine, but then it just doesn’t connect. It tries for a while and basically times out. I’ve tried all the usual turning off phone, reset router and whatnot. I’m not sure what else to try.

Any thoughts? Any advanced settings in the hotspot or something? I’m using android. I could probably connect via ethernet but it’s a pain…


You can use the android app to connect to volumio. But maybe you really want to use the hotspot?

I’m attempting to do initial setup using the android app. The volumio hotspot shows up but I can’t connect to it. I also tried ethernet to pi.

It accepts the password and everything seems normal and working well, but I can’t connect to run the setup.

With the app, you don’t need to enter any credentials. It should detect the device and then you can configure it.

It doesn’t detect the device though. Am I not supposed to connect the app via the generated hotspot? Otherwise wouldn’t the rpi have to know to connect to my wifi, without having been configured? Either way, the app isn’t finding the rpi.

Go into your devices wifi settings and connect to the volumio hotspot.
Once it connects it should use the devices browser and automatically connect to volumio’s setup page
If not open the volumio app and it should find volumio

  • You need to connect your phone to the generated hotspot from Volumio.
  • Then you can configure volumio.

If you wan to connect Volumio to your WiFi network.

  • Make and configure the conection in the network section. Wait untill you see a succesfull connection to your network.
  • Close your phone app and connect the phone back to your WiFi network.
  • Open Volumio again on your phone and let the app scan for the Volumio devices and connect to it

You can always connect the rPi to a wired connection, configure everything and then run it over WiFI.

Yeah that’s what I’m saying, the hotspot is there, I can almost connect, but it hangs and won’t actually connect, despite appearing to be all good to go (accepts password etc…).

The app simply finds nothing when not connected to the hotspot.

Hotspot is there, can’t connect to it.

Seems this isn’t a common issue as I can’t find it happening to anyone else…any troubleshooting ideas?

indeed not a common problem, it’s almost plug and play.

You shouldnt have to enter any passwords.
Just open the wifi settings, let the phone scan till it finds “Volumio-****” tap on it and it should just conect with the internal browser

I thought it was normal for the volumio hotspot to have a password (volumio2). It works and other passwords don’t (I tried just…for info).

I appreciate the help, I really do, and no offence, but everyone keeps saying to connect to the hotspot and I keep saying I can’t. It hangs. My wifi connection screen in android says “connecting” for a while then gives up and the volumio hotspot goes back into saved connections.

I’ve tried various things like forgetting the volumio hotspot, resetting router, phone, rpi etc…disconnecting from my network…connecting ethernet to rpi and phone to wifi of same network…no matter what the app doesn’t find a connection to configure and my phone’s wifi won’t connect to the hotspot…

resetting your router will have zero effect. Using the hotspot you are basically connecting direct to the rpi wifi bypassing your home router

Do you have any kind of firewall running on you phone that is stopping the connection as it may think its unsafe being as its an open network.

you could try reflashing volumio

  • You’re using the internal Wifi on the rPi, not a dongle?
  • And more important, you’ve downloaded the latest image from and not the one offered by the Raspberry Pi Imager?

And yes we will repeat, as it’s difficult to remote troubleshoot somewhere in the middle. :wink:

Yeah I get it, as far as repeating.

I’m using the internal wifi (I’ll eventually be using ethernet).

I flashed the latest volumio.

I’m trying to get my screen working so I can get into volumio directly but that’s coming with its own challenges.

Another way… forget using the hotspot, is to connect your RPi via ethernet.

On another computer on the same network type volumio.local into the address bar of an internet browser.
If that fails try entering the RPI’s ethernet IP address into the addres bar, that works too

So, after trying everything I could think of, I redownload and reflashed and everything worked peachy. Was just corrupted somewhere I guess. Always happens the first time eh?

Such is life, sorted though thats the most important bit :+1: