Browsers block Volumio.local; Volumio 2.555; Windows 10

Issue: Can’t connect to Volumio.local from my laptop runnng Windows 10 with any of my browsers [Firefox, Chrome, Edge, Internet Explorer] [Update March 09: Opera neither].

Context: Running Volumio vers 2.555 [Feb 19’19 release] on Raspberry Pi B3+ with HiFiBerry DAC.

Situation: Cannot get into “volumio.local” via my various laptop browsers, not by using the ‘volumio.local’ address nor by using my actual IP address. I know the RaspPi is transmitting -I can see it using Fing, and I am able to connect to Volumio.local with my android phone [Essential PH1] interface. It plays music, etc, perfectly. I just can’t get in from the laptop. I was able to connect to volumio.local from the laptop, using Firefox and Chrome, then Chrome stopped working but Firefox still worked as recently as this morning. Now, nada. The browsers time out and give me the useless “ERR_CONNECTION_TIMED_OUT” or “volumio.local’s server IP address could not be found” alerts.

Tried so far: I’ve tried a number of things with my laptop system, including re-setting my DNS, Winsock & Network Adaptor Drivers. All my browsers are updated, caches & histories cleared. I’ve tried shutting down my firewall. There is nothing else going on with my browsers, no other sites I can’t visit, and my wifi connection is fine. I suspect this is an issue with the browsers and some sort of internet security protocols rejecting whatever Volumio uses to set up the volumio.local connection? We know that Chrome blocks Flash, is that what’s happening here?

UPDATE (March7 ]: I’ve tried setting Windows Defender to “accept volumio.local” = zero success.

Suggestions for steps I can try much appreciated. Just fyi: I’m pretty new to RaspberryPi/Volumio world, and not a programer, so will likely ask more dumb questions. Don’t think I can send a log, b/c can’t actually connect, but if there’s a way, tell me how & I will.

Thanks in advance!

hyl :confused:

Not sure from your post whether you have tried the actual IP address of your Volumio device. Use of volumio.local can be a bit problematical.

Thanks for the reply chsims1. I did say in the first sentence: “…not by using the ‘volumio.local’ address not my actual IP address”. There was a typo: should have been “nor my actual IP address”. So yes, I have tried with my IP address and still cannot access.

Yes, it was the typo that was causing confusion :wink: If you can access the GUI from your android phone, then you can send a log ( … oting.html).

There is something very odd here in that you say it was working, but now isn’t. What has happened in the meantime? Has anything altered in your LAN, or with your router? Do you have ‘bonjour’ installed on your laptop (protocol from Apple which allows the use of volumio.local rather than actual IP address)?

Hi again chsims1,

Thanks for the follow-up! Nothing has happened -that I know of- with my router. I don’t actually have a LAN set up. I do have Bonjour, and it’s updated.

I have arrived at a sort of work-around, that might help figure out what is going wrong? After doing a bunch of cmd line commmands -flush, reset, etc- which seemed to have zero effect, I went back into my network adapter settings, and followed the sequence of unsetting and resetting the IPv4 properties, ie: unchecking IPv4 [turning it off], rebooting, checking IPv4 [setting it on], rebooting as outlined here: . When I do that, I can access my volumio.local, though only by using the actual IP address, and only while the laptop is online for that session. If I restart it, the IPv4 properties seem to ‘reset’ and my .local times out, and I have to follow the uncheck/reboot/check/reboot sequence again. This happens for all browsers (I even tried with Opera).

I assume you want to see a log from when it fails, right? Or is it helpful to see one when it works too? In either case, I’ve sent two logs. One from when I could access my .local via the laptop browser, and the second from when I couldn’t. The only difference? In the 1st log, I had done the IPv4 unset|reboot|set|reboot process, and in the second, I just restarted the laptop. Seems IPv4 does not like the volumio.local!

UPDATE, March 10, 23:00hrs: and now that work-around is failed. Again, I cannot get into the .local via any web browser and my laptop, but I can from my android phone. Sent a 3rd error log…




UPDATE March 13: I am now working on the theory that there is something in the windows/Microsoft-compatible browsers’ site security provisions.

The non-access from browsers seems to be connected to the way http:// urls are treated. In both Firefox and Microsoft Edge, my IP address for the volumio.local is marked “unsafe”. In FireFox, I have tried adding permissions using about:config, but it does not seem to be consistent. I had already added my IP address and http://volumio.local to the permissions, and that shows up in about:config. Using search, I see also that the <network.proxy.no_proxies_on> refers to <localhost,, my ip address>. But I don’t know if it means anything. That’s the only place that volumio, or my ip address appears in the about:config code.

I sent in 3 log files, but have not heard back from anyone as of the 15th. Getting a bit frustrated.

I know this is an old thread but thought I would update as I had the same issue in 2021.
My router DNS lookups basically see any domain with .local as potential mDNS attacks/leak into public DNS. so I had a spare raspberrypi configured dnsmasq to see what was going on in the logs.

Result all DNS queries actually forwarded to upstream DNS servers:

Jan 30 18:15:35 dnsmasq[12555]: query[AAAA] volumio.local from
Jan 30 18:15:35 dnsmasq[12555]: forwarded volumio.local to
Jan 30 18:15:35 dnsmasq[12555]: reply volumio.local is NODATA-IPv6
Jan 30 18:32:16 dnsmasq[12555]: query[A] www.volumio.local from
Jan 30 18:32:16 dnsmasq[12555]: forwarded www.volumio.local to
Jan 30 18:32:16 dnsmasq[12555]: forwarded www.volumio.local to
Jan 30 18:32:16 dnsmasq[12555]: reply www.volumio.local is NXDOMAIN

pi@pi4net:~ $ dig volumio.local

; <<>> DiG 9.11.5-P4-5.1+deb10u2-Raspbian <<>> volumio.local
;; global options: +cmd
;; Got answer:
;; WARNING: .local is reserved for Multicast DNS
;; You are currently testing what happens when an mDNS query is leaked to DNS
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 4761
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 4096
;volumio.local. IN A

;; Query time: 0 msec
;; WHEN: Sat Jan 30 18:53:28 GMT 2021
;; MSG SIZE rcvd: 42

To resolve accessing the hostname instead of IP address in both Windows 8.1 and 10 PC’s
The only option I found was to change the domain on my lan to something different other than .local

Test using:


Jan 30 19:12:00 dnsmasq[22281]: query[A] volumio.home from
Jan 30 19:12:00 dnsmasq[22281]: DHCP volumio.home is

pi@pi4net:~ $ dig volumio.home

; <<>> DiG 9.11.5-P4-5.1+deb10u2-Raspbian <<>> volumio.home
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16021
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 4096
;volumio.home. IN A

volumio.home. 0 IN A

;; Query time: 0 msec
;; WHEN: Sat Jan 30 19:34:01 GMT 2021
;; MSG SIZE rcvd: 57

Browing to http://volumio.home/ now works


Did using the actual IP of Volumio work, or was it just volumio.local that didn’t work, so you changed it to volumio.home?

I regularly have connection problem to volumio.local and IP on Windows 10, some days it work, some days it doesn’t. On Android phone it works.

Nope browsers don’t block on win10 and please don’t post the same things twice.
hook volumio on a wire and you will see that it’s the wifi.

Same thing twice? I asked if the actual IP was used. What is your problem?

Oke you say the same things and if want a better connection put volumio
On a wire you will see that the drop outs are gone.
The problem is mostly not the volumio.local or the ip but the connection to it.

Sorry for my fast reaction on the posts but i’m reading a lot twice or more times lately.