Boot problem only with volumio

The problem is that my Volumio won’t boot on a Raspberry Pi 4 2GB. Im using a Sandisk Extreme 64GB MicroSD card [Formated with guiformat to FAT32]. When im booting im getting “BusyBox issues sh: can’t access tty; job control turned off”

So i’ve seen a couple of thread in the community about " sh: can’t access tty; job control turned off " boot problem, none of them had helped me so far, i’ve tried disablesafemode in config.txt (disable_safe_mode=1 too) and avoidsafemode but it doesn’t stop the error. I’ve tried it in the cmdline.txt too on the same line.

I’ve tried 3 SD card. fresh boot, version 2.799 / version 2.834.

Im working on a Raspberry pi 4 2GB model, and it seem to be incompability because i’ve tried on a raspberry pi 3B and it worked.

I am powering the pi via GPIO pin [ Pin 4 and 6 ]. I have seen online that this could be a problem, but when im trying Raspbian on the same Pi everything work fine. So im kinda busted because i really want to use the pi 4 and not the pi 3 because of ram.

how did you burn it ? with the pi imager? i would say try a other image
the pi 4 can be powered with usb c that’s working for me with the pi 4

I tried 2 different version without sucess, im burning it with win32diskimager

better use the pi imager or baleno etcher did you use a 32bit or 64bit version on your pi?
and the power supply is 5v and how mutch ampere i’m trying to get a good picture of the problem…
i use the usb-c connection for power and works great… i got pi 4 4gig with a 64bit version a test version
but that one is removed for volumio… needed more tweaking …

Im not sure which version im using, you’re talking about the version of volumio ? Where do you see if the image is 32 or 64bit?.

I will check the amperage tonight

Volumio is only 32 bit currently, so just use the version from the and you should be good.

Can you post a few more lines of console output before this error?

– Don’t format you card, just burn a new image using either Etcher (or a much lighter and more privacy respecting usbimager) and ensure the verification is successful.
– Do you have any USB devices plugged into the device?

I’ve just reflash it without formatting. Using Etcher and removed all the usb devices plugged and i still get the error.

"BusyBox v.1.22.1 (Raspbian 1:1.22.0-9+deb8u4) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.

sh: can’t access tty; job control turned off
/ #"

@ashthespy bit strange the 32bit version should run fine…
i let ash do his magic :stuck_out_tongue:

I finally found the problem, but no fix to it. My project is a portable boombox and i wanted to use 2 software on it, Volumio and Raspbian OS. so i bought this:

Everything if working well with the Raspberry Pi 3B. But it seem to have compability issues with the Pi 4B 2GB. If im using a fresh boot on the initial sd card slot of the pi 4 everything is working fine.

I think my best solution is to throw this piece of garbage in the trash and just do a multiboot lol

yes the multi boot card will not work on pi4 there are extention cards but multiboot will not work…

Aha - that kinda makes sense - the current script that loads up the initramfs is hardcoded to boot from the SD card. When you add such a device, it probably changes the bootdevice?

Good question i should take a look, because on the 3B there was no trouble with the device. Do you think i could modify the pi 4B initramfs to be like the one in the 3B it there’s any difference?

No, all the (pi) images use the same image/init/initramfs. This is probably because the pi4 recognises this SD card splitter differently than the pi3.

But again, these are just my guesses! :slight_smile: