Blank Library after updating the Folder

Just bought a pi2 to upgrade from my original pi which has been running Volumio fine for a while now - I’m not a Linux guy so working my way round things.

The old pi and 1.4 (I think it was) worked fine but I wondered if the extra power of the pi2 would help with the library view as that was a bit slow. Dutifully upgraded to 1.55 and set about configuring everything.

Had a bit of fun connecting to my nas but sorted that out and thought was good to go…but no. I know it has been mentioned before but I’m not sure what else I can try - if anyone has any ideas please reply.

When I first connected to my nas, the library was filling nicely but stopped before completion so approx 40% of my tracks were not showing - but they were in the browse window. So I selected "Update this folder"and now I have nothing in the library view at all - it sits there Loading for about 30 seconds than drops to a blank library - is this some sort of timeout ?? Is my card not fast enough ?? I’m on a gigabit network and everything else is fine with the music on the nas.

Any pointers would be gratefully received.

Thank you.

I’ve a similar question: on a RPi B I succesfully installed Volumio. I mounted my NAS folder (so it seems to me…) and I see a green flag on the mount.
Now I’m Updating my library. The screen is grey, on the left corner i see “updating” with the spinning wheel, and NAS is highlited green but… no sign of any song at all. What am I supposed to do?

Thank you.

I see lots of reports of similar issues. I’m investigating on that

Something which could be related: after telling Volumio to index files on DLNA and updating the library I noticed that my server got very busy. It turns out that my server was generating MP3-files (or so it seemed) for all lossless files I have. And that was quite a job, which took a long time. During this process, Volumio had to wait. And wait. And wait… :slight_smile:

So maybe that’s what’s going on on your NAS? Maybe it’s generating/transcoding your music because of the Index request of Volumio? In the mean time, Volumio won’t be updated…

(or it is something completely different; however, it doesn’t hurt to check…)

Thanks for the suggestions - I had a thought that it was possibly one of my dirs/files with an invalid character (by the way it, originally, did fill but stopped some way short) but am unsure what characters the db can/can’t handle.

Don’t think my NAS is that clever to be honest - it is just a plain DLNA server, doesn’t do any transcoding that I’m aware of, just allows streaming access to the files. Will do some more digging and see if I can find any answers.

Thanks again.

I’m new to Volumio, and it looks like what I need, but as I am unable to see anything on my NAS (despite it connecting) I’m wondering what I’m doing wrong.

Have you managed to fix this issue yet?



I am having the same issue with empty Library. I have ~25000 Flac and mp3 files. Normal update completes fine and Browse work great.

Library scanning stops after 30sec and is empty, from looking at MPD logs its clear it did not run lsinfo all songs. I played with max_execution_time = 30 in php.ini (actually added to /etc/php5/fpm/conf.d/20-sqlite3.ini as php.ini is reset on every restart). It extended the scanning time and _loadDirForLib appears to have called lsinfo on all songs, however library is still empty. Maybe I will play with memory_limit tonight.

I am happy to help toubleshoot if anyone has something that would like me to try.

I upgraded to a Raspberry PI 2 and am no longer seeing this issue. I think it is a memory or execution time issue,

I’m running Volumio on an odroid-x2, with a quad core cpu 1.7Ghz and 2Gb memory, an still no library.
Can’t be the power, perhaps the size of my library, 2’700 folders and 34’000 files?
Library just shows a frame with albums, artists etc., but nothing in it.

Cheers - Gé


No idea why but my library is stuck on ‘loading’. Everything else is working fine including the browse page on my rpi2. I was just getting the hang of the library too :frowning:

Any thoughts? Cheers,


Posted in another topic, I did not see this one.

My library updating in itself works perfectly, however every now and than the library is wiped on start and I have to update the library from scratch again :frowning:

Same problem here, running ver 1.55.
It’s says “loading” but it won’t load.