Auralic Vega setup

I have an Auralic Vega DAC that I’m interested in hooking up to my Cubox-i. Volumio doesn’t seem to recognise it. Can anyone offer some suggestions about how to make that connection? I’m keen to try out some new DSD files with this combo!

I’m really sorry, but if Volumio doesn’t recognize it… there are really few chances to get it working…
But, let’s try to do some diagnostics:

Turn on your Cubox, connect the DAC and via ssh type:

dmesg | tail


aplay -l

Here is the output from the commands you specified:

login as: volumio
volumio@volumio.local’s password:
Linux volumio 3.0.35 #1 SMP PREEMPT Sat Feb 8 09:07:48 PST 2014 armv7l
/_ \ __
__ __ //\ \ __ __ ___ ___ /_\ ___
/\ /\ \ / __\\ \ \ /\ \/\ \ /' __ __\/\ \ / __
\ \ _/ |/\ \L\ \
\ _\ \ _\ /\ /\ /\ \ \ /\ \L\
\ _
/ \ _//_\ _/\ _\ _\ _\ _\ _/
// // // // /////////___/

         Free Audiophile Linux Music Player - Version Beta1.4

             C 2013 Michelangelo Guarise -

Volumio Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
volumio@volumio:~$ dmesg | tail
udevd[1485]: starting version 175
EXT4-fs (mmcblk0p1): re-mounted. Opts: (null)
eth0: Freescale FEC PHY driver [Generic PHY] (mii_bus:phy_addr=1:00, irq=-1)
PHY: 1:00 - Link is Up - 1000/Full
RPC: Registered named UNIX socket transport module.
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
RPC: Registered tcp NFSv4.1 backchannel transport module.
CIFS: Unknown mount option cache
CIFS VFS: default security mechanism requested. The default security mechanism will be upgraded from ntlm to ntlmv2 in kernel release 3.1
volumio@volumio:~$ aplay -l
aplay: device_list:268: no soundcards found…

I hope it means something to you :slight_smile:

So now it works: Go figger. I was able to select “Audio” from the list of output devices after restarting the computer and it started playing DSF files from my NAS, no problems.
I had seen “Audio” in the list previously, and tried it, but had no luck getting any sound. I don’t know what’s changed, but whatever it was, I’m happy!

Cubox-i4Pro, Volumio 1.4

A quick update for anyone interested. If I switch the input on the Auralic away from the USB to listen to another source, Volumio loses its connection to the USB, and when I return the DAC to the USB input I need to restart the Cubox to get the connection back. This wasn’t a problem with the Squeezebox Touch I had connected previously. It would be nice if Volumio could re-establish its connection automatically in the same way. It’s not a big deal for me, but it’s just one more detail in my spousal training program I would rather not have to address.