Audiophonics Digipi Raspberry PI I2S Digital interface


I need some help from you experts out there. I bought the I2S digital interface from audiophonics france.

But I didn’t get a signal out of it with my Raspi B running Vomlumio 1.51. It’s properly powered up, as indicated by a green LED on the board. I tried the setting for the “Hifiberry Digi” as well as “generic” in the IIS DAC section. Does anyone run this interface with volumio?

Your help is highly appreciated!


I have exactly the same problem. I tried all of the drivers, but audiophonics digi interface remains silent. I also run “aplay -l” via putty, and there is no “playback hardware devices” found (no ALSA neither), if I run i2s driver (it doesn´t matter,which one). If I turn off i2s, there is shown ALSA, but digi interface is not shown. Under the settings/audio out (via web interface) is the same thing.


Can you confirm that wiring is correct ?

2014-12-14 RPI Audiophonics Wiring.JPG

MCLK not required. In Volumio UI Hifiberry DAC is correct option.


Hi Kevin,

unfortunetly I can’t confirm any pinning, because I didn’t get any documentation with the board. And it is just a piggy board plugging onto the Pi just like the IQaudio or Hifiberry stuff. So there are no coloured wires to connect it to the Rasperry Pi B. Please refer to the link I posted initially.

Further on this is no DAC on it! It’s simply converting IIS to S/PDIF by a Wolfson WM8804G!



Additional Info:

I just checked, that at least the WM8804G on the board is wired correctly to P5 of the Pi.



Yes, the wiring must be correct, audiophonics digi is connected directly on raspberry via P5 connector. I think that there is a problem with drivers, but it is wierd that the digi board isn´t recognized. I think that under “aplay -l” I should see “audiophonics digi hardware sound device”, but it´s nothing there. If I turn off i2S driver, I see ALSA sound device, but if I turn on i2S, I don´t see anything. Like there is no sound device.

:blush: really sorry I didn’t read things properly and I was talking about Audiophonics i2s DAC not DIGI :blush:

Not sure at all if the wiring is identical so please ignore that. :question:

It seems that people are having problems with the HiFiberry Digi too. Haven’t got any of this kit so can’t really offer any advice.

Apologies again :blush:


Yesterday I tred diferent OS, RuneAudio, but the problem remains the same. I really don`t know what to do… If I onlny knew, what and where to look… Any ideas please?

I’m in contact with David from Audiophonics. He said he had one customer with Volumio 1.5. These customers problem turned out to be bad soldering on the P5 connector. sound that at least it is working with 1.5…

He said he’ll try it with Volumio 1.51. I’ll keep you informed.

if any of the other members can advise, please feel free!



Ok, thanks fot the tip, I will resolder P5 tomorow, just to see if this is the case. So it should work with hifiberry digi i2s driver, if I understand correctly?

I just connected different dac (not DIGI) to P5 and it works. So it look like that the soldered connector to p5 is ok… Problem persist with DIGI dac… I will resolder p5 connector again tommorow, just to be shure.

Good luck guys,

I have had crackling on playback which i have assumed to be bad soldering of P5 but haven’t proven it nor resolved it.

Just think it would have to be some pretty bad soldering to get no signal at all. :open_mouth:

Let us know how you get on.


No, resoldering doesnt help. Problem remains. I just test it, digipi does not work, the other tested dac works. I also look in spdif optical out, where it should be light, but there isnt any. On putty aplay -l says: no sound device :frowning:

Question: with digipi also came P1 connector and IR sensor. Should I also solder P1 connector? I do not need IR, i suppose that P1 connector is just for that…

In my opinion P1 is only needed if you want to use the IR receiver. All signals and supply lines for the WM8804 are on P5.

So far nothing from audiophonics! Very poor that they are advertising this as compatible with volumio, which it isn’t. At least out of the box.



Yes, I suppose that I will write them and return the product. I am very disappointed… I will order hifiberry digi.

Hey, what about this guide: ? I tried, but I cannot found /etc/modprobe.d/raspi-blacklist.conf (2nd step). Could it help? Or are those steps/settings already inside hifiberry digi driver?

You said that this dac uses a wolfson chip (WM8804) for the actual dac. Have you tried to use the wolfson settings and drivers?

According to this link the wolfson also uses the WM8804 … udio-space

I stepped back to 1.41 - same result. Not working!

I tried it but still the DigiPi doesn’t work. aplay -l says no soundcard available.



I am out of ideas. Nothing seems to be working, the Audiophonics support is also failed. I haven´t tried wolfson settings (like proposed MobeyDuck), but it seems that there is no driver for this- or is it?