Audio stutters/stammers/interrupts on wifi

I just installed version 2.246 successfully. I play via AirPlay from my PC. The audio is wonderfull, but it repeatedly stutters and stammers before interrupting a few seconds, then playing again before stuttering and interrupting again et cetera.

I suspect this could be a bug.

I am using a Meridian Explorer USB DAC and a Raspberry Pi 2. For playback I tried the DAC’s internal clock as well as the Pi’s clock. Wired does the same thing as wifi. I turned off BT in my home.

Does it still stutter if your Pi 2 and PC are both connected via Ethernet ?

If so, do you get any stutter if you play a wav file on local storage (sd card or USB on the Pi) back directly from the command line using aplay ?

Thank you. I can’t connect with running volumio on Telnet or SSH with PuTTY: “Connection refused”.

So that’s another problem.

Also I would need instructions on how to use APlay.

I hope to hear from you.

More issues:

  • Other DAC’s don’t work.
  • When switching to a different output Volumio freezes shortly after. After restart, it works.

This should have been solved in last version, please update and retry

Thank you Michelangelo! It is better. There still is some stutter. The option to use de DAC’s clock is no longer selectable.

Still, my great admiration for the great product you produced! :slight_smile: (Volumio of course!)

I will test further tomorrow.

PS: What is the option to use DAC clock?

Welcome :slight_smile:
I thought I saw it in the dropdown for the volume mixer, but I am now thinking I might have been hallucinating or something. :open_mouth:
(Is Volumio supporting asynchroneous DACs?)

I see what you mean.
It’s a mixer naming used in XMOS which does not affect absolutely nothing. It’s not related to async transfer.
Async transfer is intrinsic of the USB receiver and there is no way to control it from software. So you just misunderstand it.

As you can see, it’s mentioned in the changelog:
Do not show XMOS Fake HW mixer

I’ve removed because it could have created confusion :wink:

Unfortunately, there is still considerable glitching in audio.

Try this (if you are on latest version) go to playback, select a different audio output, save. then select again your USB output

let me know

When I visited the front end with my browser, it came up with a setup wizard, which I followed. My DAC was set appropriately (and showed “Meridian Explorer USB DAC” after the setup instead of just “USB DAC” like before). Then I connected via AirPlay and Volumio froze. So I restarted Volumio and connected via AirPlay and there was no sound. Then I selected another audio output, and then back to my USB DAC again. When connecting, Volumio froze again. Restarted, then there was music, but still pretty well ticking and stuttering unfortunately.

Maybe this makes any sense. Volumio is (I think) very complicated (as a former IT student and hobby programmer), so I have complete respect for your work. I am not in a hurry. I wish I could help, but I am getting old and tired and Linux is probably too complicated for me. :wink: (so I’m not bragging :mrgreen: )

My SA9023 USB DAC does not stutter. However, I am not sure if it sounds its best…

Anyway, is it possible to debug my Meridian Explorer USB DAC that does stutter? It has a lot more quality… :slight_smile:

Still, the SA9023 doesn’t stutter, but it ticks, it skips tiny bits of music, audibly.

I have had this issue with Volumio 1.51 too.

P.S: When changing the output setting to the other DAC, then connecting with AirPlay, Volumio crashes.

I haven’t been able to use Volumio (and my set) for about three years now. I hope my issue gets addressed. Maybe I will sell my HiFi. (although that is the last option I think :laughing: )

I believe, back in the time I bought the Explorer, they explained there are at least two methods of asynchronic transfer. The first is that the sender sends a send-request to the receiver, and the receiver accepts when it needs the next frame. The second is different: in this case the receiver requests a frame to the sender when it needs it. I believe the Explorer is the latter. Maybe you know what I mean. :wink:

I know it contradicts your nickname… But, why don’t you try the Mini86? It’s my configuration of choice with USB DACs… :wink:

Of course, we’re not settling and we ll keep on looking on how to fix this USB issue (still fighting with USB hardware limitations of the pi)

I wil take a look at it! :slight_smile: For what it’s worth: 2.285: better but now I have a kind of ‘bubbly’ effect (like with water).

If the issue is the Pi, I will consider the Mini. :slight_smile:

How much current draws the Mini? Can I use my own power supply? Can Volumio be reinstalled when necessary? Should I take the SSD or the HDD version?

Just a few questions.