Audio phonics sabre DAC network streamer kit problem

Please can you help…

I have a Raspberry Pi2 and a new Audiphonics Sabre DAC (I-Sabre V3 DAC ES9023 TCXO )

I had the two working fine with both Moode and Volumio2; the problem was that it was all ‘bare-back’ and held in place with elastic bands, so I went for one of these: … 11137.html

Now the DAC works well; it will play into my hi-fi. However the screen is dead and there is a flashing blue light around the outer edge of the power button (The white light in the middle of the button that I’ve seen in the videos isn’t on).

After a Google trawl, I thought I knew the answer - the DAC needs a minimum of 6v whereas, when it was working fine the linear PS was giving the Raspberry Pi 5.1v (The DAC got its power from the Pi). The DAC in its new black box has its own PS and this time the Pi gets its power from the DAC). So I tweaked the Linear PS to give 6.2v. But, I still get the same result.

There’s quite an extensive thread on RuneAudio on this and it seems that one needs to re-program the Pi with a load of mumbo-jumbo code which I hadn’t thought was necessary.

I’ve checked and jiggled the wiring but I still have the flashing blue light and no screen. Does anyone know the answer?

I have contacted Audiophonics.