audio dropouts

Hi hope the collective knowledge can help

I have just installed volumio on my Pi however when i play a track from my nas i get a lot of audio drop outs. this is through the usb dac or the analogue out
i have tried wired and wifi network conection
can anyone advise what i can do to resolve it.

Hi carlymart,

i was in the same situation as you until i read this post :

The thing is there is an issue with USB audio on Raspberry Pi (that would explain the reason why you are having problem with your DAC but not necessarely why you encounter the same with the Analog out).

Try to update your Pi firmware

sudo apt-get update sudo apt-get install binutils sudo apt-get install rpi-update sudo rpi-update

It solved all the crack and pop problems in my setup (Raspberry Pi + USB DAC).

But i’m affraid the problem comes from your network if you are having the same issue with the Analog output.

Any advancements on this?

I just set up Volumio 1.5 on my Cubox 2i, connected to a NAD D3020 amp with built-in amp.
It’s a sweet setup, and I got it working well for the most part, but I am still experiencing occasional pops and hicks when streaming over AirPlay. Modifying the shairport start-cmd line in the PHP config helped, but its still not entirely gone.

I see you RPIers updated the rpi software (rpi-update) and things were better. I do not have that alternative. Anybody have a clue what libs/software is included in that update that may have helped this?


I had to do a bit of fine tuning on the network to get the system (see my signature) to work.

Network is all Mikrotik based so it is easier to fine tune the network using built in tools in the router and AP’s.

No drop outs after fine tuning the network.

Thank you. Care to share some details regarding the network tuning? I’m currently wired, but plan on going Wifi before this setup is finalized.


This is what I did. Not all of it may be necessary depending on your situation. I have multiple video streams, VOIP, mega pixel security cams and home automation running on this network.

  • Router CPU no more than 5%, memory at less than 20% - Model CCR1009

  • no spanning tree (RSTP) on LAN bridge. Cannot run SONOS if this is turned off. Turning RSTP off leaves you open to network loops.

  • DHCP authoritative for fast dhcp resolution

  • Gigabit ports with LAN interfaces sharing a dedicated switch chip when bridged. I plan on moving to a gigabit managed switch to offload resources even more on the router. Switch would connect via SFP to the router.

  • bonded dual gigabit links to Synology NAS

  • DNS cached

  • Local time server so that only one host on the LAN interfaced to the internet time servers

  • disabled unnecessary services on the router

  • Tuned wireless radio links to between 55-70dbm between stations and Access Points(AP). Too strong a signal led to lower throughput/dropouts.

  • Wireless bridging between AP and station serving RPI using TDMA (NV2 in Mikrotik terminology) protocol to reduce latency. RPI cabled directly to station. No wireless adapter on RPI

I miss the days when I could get great sound just by lowering the tone arm on my vinyl :slight_smile:. I hated getting up every 15-20 mins to turn the record side over though.

I had tried all suggested solution but still can hear the popping sound unless i stop and play again.

I switched from wired to wireless, no change.
Again; playing files from NAS (320kbps MP3s) via Volumio Web UI has no issues.
The slight cracks and pops come when playing over AirPlay.

Changing shairport startup command made things quite a bit better, but its still not perfect…

I’m facing same issue
Streamin web radio is working fine (or browsing from my synology NAS)

Redirect music on volumio2 through airplay is raising a lot of drops (I mean I got more drops that sound …).

My setup is RPI2 + Hifyberry amp