Apt update crashes system, mpd no longer works after reboot

I just installed a new image of volumio on my pi3b, then ssh’ed into the system and did an update and upgrade. There were dpkg errors during upgrade and after a reboot, mpd no longer works.

I have tried this three times, same result each time.

The output after apt upgrade:

Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages will be upgraded:
dhcpcd5 e2fslibs e2fsprogs firmware-ralink libblas-common libblas3 libcairo2 libcomerr2 libdrm2 libfreetype6 liblapack3 liborc-0.4-0 libpam-modules libpam-modules-bin libpam-runtime
libpam0g libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpixman-1-0 libsdl1.2debian libss2 libva1 x11-common
24 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 6288 kB of archives.
After this operation, 1994 kB of additional disk space will be used.
Do you want to continue? [Y/n]

The last lines of output after upgrade show

dpkg: error procapyessing archive /var/cache/apt/archives/firmware-ralink_1%3a0.43+rpi6_all.deb (–unpack):
trying to overwrite ‘/lib/firmware/rt2661.bin’, which is also in package firmware-misc-nonfree 20161130-4~deb8u1
Preparing to unpack …/libblas-common_3.7.0-1~bpo8+1_armhf.deb …
Unpacking libblas-common (3.7.0-1~bpo8+1) over (1.2.20110419-10) …
Preparing to unpack …/libblas3_3.7.0-1~bpo8+1_armhf.deb …
Unpacking libblas3 (3.7.0-1~bpo8+1) over (1.2.20110419-10) …
Preparing to unpack …/liblapack3_3.7.0-1~bpo8+1_armhf.deb …
Unpacking liblapack3 (3.7.0-1~bpo8+1) over (3.5.0-4) …
Preparing to unpack …/libva1_1.7.3-2_armhf.deb …
Unpacking libva1:armhf (1.7.3-2) over (1.4.1-1) …
Preparing to unpack …/x11-common_1%3a7.7+16_all.deb …
Unpacking x11-common (1:7.7+16) over (1:7.7+7) …
Processing triggers for systemd (215-17+deb8u8) …
Processing triggers for libc-bin (2.19-18+deb8u10) …
Errors were encountered while processing:

Anyone have this issue with the most current image?

Any ideas what is causing the error?

Upgrade is known to break Volumio due to tweaked package. Do do that.
What’s the reason for you to upgrade?

I normally update and upgrade any new install. It is habit I guess. I don’t have to do so if upgrading breaks the system.

The solution to fix mpd if you upgrade using apt is to add the following line:

sudo ln -s /opt/vc/lib/libcm_host.so /usr/lib

Odd that the library location changes, but so be it.