Apple external superdrive (Usb CDROM drive) won't work, please help

Hello everyone,

I have an issue, i don’t use my external cd rom drive very often, but it worked with volumio some times ago (maybe with volumio 2 can’t remember).

And now, it won’t accept to insert a disk, so it won’t load it of course.
It seems that the drive isn’t mount or detected.
The power is ok because i hear it when i start the raspberry and i tried with a powerfull power supply too.
I tried all the usb ports and restart just after…
I also tried the drive on my computer and it is working nicely.
Any idea please? Thanks a lot !
(I have virtuoso plan)

Is the drive connected via a powered USB hub? If not, it may receive insufficient power tot start up the drive (even can result in Pi failure or card corruption). Typically, it will make a few ticking noises, then stops. If the drive has been working with an earlier Volumio setup, a dedicated power supply could make a difference.

it’s powered by usb only, it’s the apple superdrive, in fact i can’t put a disc inside because it is automatic, when we insert a disc a little inside the drive normaly “eat it”…
i don’t think it is a power issue because it worked before and volumio team say that model has to work without issue and, i already tried a powerfull power supply.

My own setup (latest Volumio 3.x) works seamless with an OEM CD player connected to a USB hub. In the past (on Volumio 2.x) I also used an Apple Superdrive, that indeed worked independently. I still have the thing, but I can confirm that it does not work on the latest Volumio, also not when connected via the powered hub. Weird.

it think i progress, i found a youtube video (link below) and now the drive accept to insert the disc but i don’t have the cd source in the sources menu so i can’t play or rip discs.

ok now it is working but i have to unplug my dac so now this is a lack of power i think

I did not install the additional software as suggested in the video, but the SuperDrive does not work on the powered hub or when directly connected to the pi (no other usb devices connected). This seems to rule out a power issue IMO.

on a powered hub if you follow the video it has to work

Well, I don’t want to make my current setup unstable with new software that I do not need for my current (non-Apple) drive.