Another Synology mount question....


New to Volumio, not new to file sharing, NFS stuff, Raspberry Pi (I use OSMC on RPi as video players on my home network), etc.

However I can’t for the life of me figure out why my Volumio on my RPi isn’t seeing my NAS music folder. I’ve checked and rechecked my NFS settings, and they appear to be wide open. Volumio says it sees the mount, and that everything is fine. The file path looks strange to me though - I try to change the slashes to line up properly, and Volumio always makes edits to them. Maybe that’s part of the problem? Not sure. I am posting a few relevant screen shots so you can see what I mean.

Can you all help?

Deeply appreciated!

Putty screenshot.JPG
Volumio screenshot.JPG
Synology screenshot.JPG

try to remove the first / from the path

If you can ssh into your device, can you have a look in ‘/mnt’ for your NAS and see if you can see files there?

When I try to do that, I get an error, with the attached message in the upper right corner.
remove slash error.JPG

I tried that. Not sure what it’s supposed to show me at that point. See attached.
mnt thing.JPG

Wonder where the “:” comes from

You got me. Any suggestions?

The “:” comes from the syntax that NFS uses for mounting (differs from cifs). From the error message, I think you need the initial “/” in your path.

The reason that I asked you to look in /mnt was to see if the NAS was actually mounted or not. On my system:

volumio@volumiokitchen:~$ cd /mnt volumio@volumiokitchen:/mnt$ ls INTERNAL NAS UPNP USB test volumio@volumiokitchen:/mnt$ cd NAS volumio@volumiokitchen:/mnt/NAS$ ls TheSutherlands

if I change directory into /mnt, and ‘ls’ the contents, then I can see a NAS directory.
If I change into that directory (cd NAS), and again list the contents, then I can see my actual NAS. All my music files are shown in that directory (TheSutherlands).

Edit: actually might be simpler to just issue the command ‘mount’ and see if you can the NAS shown in that list. In my case, the line of interest is: on /mnt/NAS/TheSutherlands type nfs (ro,relatime,vers=3,rsize=131072,wsize=131072,namlen=255,soft,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=,mountvers=3,mountport=892,mountproto=udp,local_lock=none,addr=

Thanks for the response. I tried that, and here’s what came out, in what I think is the relevant section of the text: on /mnt/NAS/DS212j type nfs (ro,relatime,vers=3,rsize=131072,wsize=131072,namlen=255,soft,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=,mountvers=3,mountport=892,mountproto=udp,local_lock=none,addr=

I see the NAS listed there, but I don’t know how to read if there are problems in the rest. Any thoughts?

So, your NAS is indeed mounted … good. Have a look in the ’ /mnt/NAS/DS212j’ directory, and you should be able to see your music files. Do a ‘ls -l’ command to see the file permissions.

Thanks chsims1. I’m at work all day, so I’ll give it a shot tonight or tomorrow morning. I’ll keep you posted. Your willingness to help out is deeply appreciated! :slight_smile:

From another post on the forums impossible-see-nfs-music-folder-with-volumio-and-syno-t11265.html , I suspect that Synology has changed things around a bit with permissions and NFS. Try entering one of your NAS user accounts in the Volumio UI mount screen.

I tried that last night - with and without “logging in” from the Volumio UI (I used my ‘admin’ account level). Both yield the same result - the NAS will mount, but won’t scan or bring up my library.

Or let me ask you this - I usually give this about 10 minutes before deciding it’s not working. I have about 330 CDs and DVD-As ripped to FLAC, so not a huge collection, but probably larger than most people’s physical media collections go. Should I wait longer than that? It would be great if Volumio would show some sort of progress bar or indicator for scanning/updating the library, but if it’s an “all or none” indicator, maybe I’m just not giving it enough time to compile the database…??? Let me know what you think.

Thanks again!

EDIT: I am NOT using wifi. It’s all wired gigabit in my home…


Thanks everyone. I actually found the answer on the RuneAudio forum (of all places).

It was the squash setting within NFS permissions. All I had to do was change the squash setting to “map all users to admin” and it found the library and loaded everything up.

Thanks for all your help!


Good job!
No problem with permissions accounts?
You had to enter login and password to see your NFS shared folder?

Correct - no login or password required. Strange, I know. I also had to add the “/” at the end of the directory to get it to work.

Works like a charm now. And this new IQaudio DAC Pro is jaw-droppingly clear! Making even my old, crappy headphones sound like new again. My 16/44 FLACs sound great, and the DVD-A rips at 24/96 are lush and deep. Now I just need to add the Amp+ and hook it up to some bookshelf speakers…

Sent from my Pixel 2 using Tapatalk