Allo USBridge Signature not working well with Chord Mojo

Hello all

I just received my Allo USBridge Signature pre installed with Volumio and so far very disappointed with the results.

The problem is I am getting a cracking sound when playing some tracks via Tidal (my main music source) akin to playing a vinyl record and the sound is generally quite harsh and shrill. Previously I was running Volumio on an Intel Atom based box with no problems. In fact the sound was very good. I was just hoping the Allo would provide just a better sound but unfortunately this is a big step down.

I have upgraded the pre installed Volumio to the latest build, reset to factory settings. I have tried connecting the mojo to both the clean and dirty usb outputs but nothing makes a difference.

I also tried connecting my old Arcam irdac but unfortunately volumio would not recognise it (although on the intel version volumio has no problems with the irdac)

Does anybody have experience of the USBBridge with the Mojo DAC. Do I have a dud piece of hardware or is this a known issue with the USBridge?

All comments gratefully appreciated


I’ve read in many places of people complaining about the same symptoms…
Sorry but I am not able to help there…

Allo told me to download their ethernet driver from their website and that fixed the problem

sudo cd /usr/src*
sudo wget*
sudo sh*

And the USBridge needs a good run-in to start to sound good. With this driver and a couple of days run in its starting to really open up. Just compared it to my previous box
(early Inuos Intel Atom based machine) and its now a definite improvement.