Allo USBridge Signature AX88179 Driver


I’m posting this in the hope that an Allo USBridge Signature owner with better Linux skills than me might read this!

After upgrading Volumio in the past, it’s been necessary to update the Asix AX88179 driver from Allo’s website to stop the dreaded audio glitches when playing hi res music over ethernet.

With the latest update to v3+, this is no longer possible, as Allo hasn’t compiled a driver for these more recent Linux kernels and they don’t seem to be playing ball any more.

Obviously, there’s little point continuing my premium Volumio subscription when I can’t make use of the latest and greatest updates and I’m desperate not to admit the Usbridge Sig is obsolete, as it worked so well with Volumio before.

I found the following link, where some kind of IT black belt has managed to compile the driver without Allo and has included instructions on how to do it:

GitHub - ce-designs/USBridgeSig-AX2v0: A fork of Allo’s ASIX ethernet driver 2v0 for their USBrigde Sig.

However, following all the steps in the above (and after tweaking rpi-source to use Python3 by mod’ing the 1st line of /usr/local/lin/rpi-source to #!/usr/bin/env python3), the process fails every time I come to install and compile the driver, with the following message:

make[1]: Entering directory ‘/lib/modules/6.1.70-v7+/build’
make[1]: *** No rule to make target ‘modules’. Stop.
make[1]: Leaving directory ‘/lib/modules/6.1.70-v7+/build’
make: *** [Makefile:8: default] Error 2
make: Leaving directory ‘/usr/local/src/ax88179_178a’

Compressing the driver binary using xz-utils
xz: /usr/local/src/ax88179_178a/ax88179_178a.ko: No such file or directory
Compression failed. Aborting the install procedure…

If anyone has any ideas on how to fix this, I’d be forever grateful! I feel we’re so close to keeping these alive!!

Thank you in advance,


I was about to try Volumio again after several years and found your post.

I did some checking and looks like the drivers are still there.


Am I missing something?


Hi Kamil,

Thank you for replying!

This is where I get confused. Every time I updated Volumio in the past (before v3), I’d get unbearable pops and clicks in the music played over ethernet.

To fix this, each time I had to update the AX88179 driver from Allo’s website. Running their seems to pick the drivers from the relevant kernel folder on their site.

Today the kernel is way newer than any of the corresponding drivers on Allo’s site, hence the doesn’t work and l’m currently plagued by the pops and clicks using 3.611!

I think (but don’t quote me), Allo used a customised version of the driver for the Usbridge Signature.

Shame, as I don’t want to switch from Volumio, but I don’t want to start again with new hardware either.

Best regards,


I just started volumio and got same issue as you - remember it form the past.
Frankly speaking this was exact reason why I moved to gentooplayer - no fancy UI but SQ is in a different legaue, especially when running fully from RAM (available in options).

Since I already booted volumio let me spend some time to figure out AX drivers.

It’s tempting to try gentoo, etc, but I’m too deeply invested in Qobuz, so I don’t have a lot of other options.

I can roll back to an earlier Volumio with the Allo drivers, but then it seems a total waste of money me paying for the Primo subscription! Can’t win.

I’m sure I was getting close to a success, but seemed to overcome one hurdle only to hit another and it became too frustrating

I use GP with Roon.

The earlier Volumio versions use 5.10.92-v7+ armv7l kernel version, but the one that introduces Tidal connect HI-RES FLAC (Volumio 3.569) uses kernel 6.1.58-v7+ armv7l.
The new kernel needs new ethernet driver, but it is missing from the Allo support page.
This makes incompatibility between Allo USBRIDGE Signature and Volumio software version since the 3.569.

So, you also have another PC, etc running Roon Server? Roon does look great!

From what I’ve read in various places, I’m not sure Allo are still going, so we might never see an updated driver from them. Gutted, I love my Usbridge Signature!

Has any of you considered to disable the AX88179 driver alltogether and use a usb-to-eth adapter with a different chipset? Just a thought.

Roon is runnig on my Synology NAS.
I give up on volumio - Gentooplayer is being updated frequently and developer ensures asix lan works with new kernel. Currently my GP runs on 6.1.73 64bit and I don’t care about any drivers.

1 Like

I’m surprised, because the asix driver is generic for 6.1.y, and, at least for our x86 version, there has not been any issue with it.

ah, that explains it, sort of…

I think it’s better to ask Allo to publish their patched driver for kernel 6.1.x

then it will be possible to include the patched driver on the Volumio image, with no need of manual changes

1 Like

Hi, I did a clean install (v. 3.611) on my Allo Usbridge Signature and it plays fine. I have an i2s Ian Canada Transport Pi Digi with Isolator on Usbridge.

Are you playing files locally from SD card / USB flash drive, or over ethernet?

I’m ok with CD quality over Ethernet, but anything higher quality stutters like crazy

(Mine was also a clean install, same version)

I mostly play from Qobuz. Now I tried DSD from NAS - 2.8 Mhz approx. 5645 Kbps works fine. DSD 5.2 Mhz is cuts.

I didn’t fully understand what you meant before. . . . . . this is interesting!

So, if I understand correctly, you have an i2s Ian Canada Transport Pi Digi attached to your Usbridge Signature and you connect this to your DAC?

Have you also tried with a USB connection to the DAC?

I can’t understand why attaching another HAT would solve the networking issues, but if this works, I might consider copying your setup

I haven’t tried it via USB.

I have Allo Usbridge Signature with IAN CANADA TRANSPORTPI DIGI, IAN CANADA ISOLATORPI II via HDMI ( i2s) to R2R DAC Musician Draco

Power supply: Allo Shanti and 2x LIFEPO4 18650 direct to clean side of isolator

Sounds like a nice setup, thanks for the info.

Anyone else here confused why someone else’s Usbridge Signature, running the same Asix driver, but with a HAT added would circumvent the pops / clicks problem?!?! I’m lost!!

Knowing my luck, I’ll reproduce this setup and it will make things worse :slight_smile: