Allo Boss Player not detectable


This is my first post in this forum. After scanning through the help section I did not really see a clue to my problem. I received the Allo Boss Player (Pi & Boss Player in acrylic enclosure) a few days ago. It worked great for a day until I discovered there was an update available in the settings under system. I updated and rebooted after which the device registered on my home network, but would not playback due to an error I do not recall anymore. It was pretty long and I should have tried to copy it down but did not. Then I figured I reset the device to factory settings, assuming that would return it to the working order before updating. After the reset to factory settings I can no longer see the device on my home network. I have additionally checked with the Fing app on my phone. On the Allo Boss Player the power led is on (red), the ethernet ports orange led is on, while the green led is on most of the time, sometimes intermittent. Should I remove the Micros SDcard and reinstall Volumio with this image ( version 2.323?
Any help would be greatly appreciated, thanks!


Yes, your best bet it to reflash from scratch… Sorry about that…