Airplay via Volumio (USB-DAC) Volume to low


I´ve the following configuration:

Raspberry PI 2, XMOS USB DAC

I use the following services:

  1. Spotify -> functions fine
  2. NAS -> functions fine
  3. Airplay -> functions, but the volume is very low. When I increase the volume the sound has not the same quality as with Spotify and NAS. It has not the same dynamic! I believe, that it is a Math-problem. Is there the possibility, that there is a cut of some bits? The difference of volume and dynamics sounds, that 2 bits are lost.

Is this a known issue and is there a solution for the problem?

Thanks in advance!


I’ve found a solution for this problem.

cd /home/volumio

With this update the volume problem has vanished!


Christian - thanks a million for that post!

Airplay was not working at all on my new Volumio setup. And after SSH’ing into Volumio and executing your three commands fixed it! Sounds great too.

Thank you for posting sir. :slight_smile:

ssh: cd /home/volumio sh reboot

I tried that on Volumio 1.55, but I got a lot of errors: “Permission Denied”.
Is there a SUDO missing? Or what is the trick?


If you get permission denied on Linux it’s probably because your account isn’t allowed to execute the command.

So try it with an other user account. Sudo basically is made for this kind of use and makes a superuser do stuff. By default it uses the root / superuser account but you could use sudo with other accounts although su would probably be preferred for that usage.

Tldr; try sudo and then the commands