Airplay on Odroid C2

Hi wonderful people from Volumio.

Will you be including airplay support for c2 in the next release?

As far as I am aware, Airplay is supported by Volumio on the C2 … at least, shairport-sync is running by default on a C2 here (but no way of testing).

Ya. They used to work. I reflash the the sd card with the new firmware and can’t detect airplay device anymore.

Which version of Volumio are you using … v.2.166?

Edit: I’ve just reflashed 2.166 and Airplay is running ok (again, I can’t actually test it)

[code]volumio@volumio:~$ sudo systemctl status airplay
● airplay.service - ShairportSync AirTunes receiver
Loaded: loaded (/lib/systemd/system/airplay.service; disabled)
Active: active (running) since Wed 2017-06-07 08:54:44 UTC; 1min 22s ago
Main PID: 1641 (shairport-sync)
CGroup: /system.slice/airplay.service
└─1641 /usr/local/bin/shairport-sync

Jun 07 08:54:44 VolumioOdroid systemd[1]: Started ShairportSync AirTunes receiver.
Jun 07 08:54:44 VolumioOdroid shairport-sync[1641]: startup
Jun 07 08:54:44 VolumioOdroid shairport-sync[1641]: avahi: avahi_register.
Jun 07 08:54:45 VolumioOdroid shairport-sync[1641]: avahi: register_service.
Jun 07 08:54:45 VolumioOdroid shairport-sync[1641]: Avahi without metadata

Its v2.166. I think i’ll refresh again and see how it goes. Thanks for confirming that its works on ur end

Just tested airplay. Status shows ok - but I couldn,t find airplay device

update1: after reflashing the SD card - airplay came back… :slight_smile:
Thanks for the help

update2: problem with finding airplay device came back. although airplay is running in Odroid - can’t seems to find the device.
One quick workaround that works is - to save the player name again in the system setting. Once saved - the airplay device came back online. Weird. Definitely a bug

There were similar reports for shairport-sync on a RPi recently. Michelangelo has made changes, and these were incorporated into v2.185. Unfortunately you’ll need to wait for an Odroid image to be released.

Thanks chsim1 for letting me know this.