Add Pi To Windows 10 Network

Hi can someone give me some pointers please
Cannot access Volumio over Windows Network
I used to be able to do this before updating the volumio version to the latest version
I need to do this to add music files to the USB sticks on the Pi as it is pretty inaccesible
I have enabled ssh on the pi via putty thinking that would make the Pi discoverable
It shows the Pi as a Media Device but i cannot get it to show as a Network Location

If there is something I am missing here please help

When you say it’s not accessible, exactly what do you mean? Just that’s it’s not visible under the network list, or that you can’t access it at all?

For example if you go into Windows Explorer and type either \ or \> does that work. Obviously substituting the actual IP address or network name in as appropriate. You can get the IP address of the device from your router normally, as it should offer a list of its active clients of which your device should be one.

Since SMB1 and Winbind have been removed from Windows, the network visibility is very flaky as it relied upon those to operate.

DarrenHill may be right, I currently tried to add win10 machine to my workgroup of win7 and winxp machines an was not able to see other computers from win10 even after I manually added smb1 protocol to win10. What’s worse other computers are not accessible even by entering IP address directly.There is lot of talk about it on web, but none of it helped. As I understand this problem was introduced some win10 updates ago. Funny thing that win10 machine and public share is visible from other computers.
Another problem I need to mention that since last Volumio update I cant browse network from it, but can only add music sources by entering IP manually.

Thanks for your answers but finally found a solution that worked for me
Was from an online forum … p?t=206123

The part that worked for me I have copied and pasted on here

Re: Unable to connect to raspberry pi after windows 10 updates
Thu Feb 22, 2018 8:45 pm

Had a similar problem recently with Windows Update, it turned off Samba on Windows 10.
Control Panel -> Programs -> Turn Windows features on or off, wait for the list to populate, then scroll down to “SMB 1.0/CIFS File Sharing Support”, and tick the box (if it’s been deselected as happened to me). Reboot, and try again.

Hope this helps,

People need to learn that enabling SMBv1 is a bad idea. It is over 30 years old. … are_attack … on_Ukraine … a-p/425858

You don’t need it.
You know the names off your machines or the IP address.
Just type the machine name in the address bar: \volumio

People type the whole day addresses in there web browser but are to lazy to do it in the file explorer?
And you don’t need to type it all the time. You can pin the shares to quick access like you have bookmarks in your web browser.

By the way:
If you really want to browse the network you don’t need SMBv1.
If you enable network discovery you should see the machines.
If they don’t show up they have it disabled.
Here i can see for example a Fire TV and network cams without SMBv1 enabled on the windows machine.