Accessing USB drive via network

Hi. I tried searching, but couldn’t find any recent solutions.

I’m running Volumio (Virtuoso, latest version) on a Pi, with music stored on a USB SSD drive connected to the Pi. For the most part it works well, no issues with the USB drive not getting enough power or anything like that.

But I’m trying to access the USB drive over the network from my Mac, to add some new music to it without having to shut the Pi down, unplug the drive etc etc. And I’m having problems.

I can see the folders & files on the drive from my Mac just fine. I use Finder > Go > Connect to server, enter the smb://192.blah.blah address, connect as guest, and then I’m offered a choice of Internal Storage, NAS and USB. I choose USB and up comes the drive, and I can browse the files and folders and so on as you’d expect.

But the problem is that I can’t actually change any of the files on the drive, or add any files to the drive. When I look at Get Info, every folder shows as being locked, and although I can appear to unlock them, write access isn’t actually allowed.

I read a similar topic here which mentioned that reformatting the drive to ExFaxt32 might help, so I did that. But it hasn’t helped.

Any idea what I’m doing wrong? From what I’ve read, the same process seems to work with Windows, but I don’t have a windows machine to try.

hello Dr_Endarken. I’ll answer you but I’m not an expert. I adopted the same procedure as you, I couldn’t get Volumio to read the shared folder on my central server with all my music (mp3, flac, etc.).
after some initial problems with a crucial ssd, i bought a 1tb usb memory. premise: I use a Windows system (desktop w10 and server os whs 2011). the memory device can be reached at ip \ 192.blah.blah.blah \ usb \ folder.
my experience is not valid for mac or linux systems.
then on my w10 system I formatted the usb memory in ntfs, I go to drive properties -> users and groups -> security -> modify and activate all the controls for “all users” as in the picture. I’m sure the same thing you can do on a Mac system with Finder.
I solved the problems and can now add new music to my Volumio without disconnecting the USB memory.

1 Like

Hi tavellone. Thanks for your attempt to help, and it’s great that you managed to get it working for you. But unfortunately it doesn’t seem to solve the issue for me.

I’m unsure whether you mean you make the changes to the USB drive security settings with the drive connected to the W10 Machine (I think this is what you mean) or by navigating to it via the network when it is plugged into the Pi.

But neither of those things works in my case. The USB drive, when accessed via the network, remains impossible to write to or alter, regardless of what I try to do with the sharing & permissions settings.

I suspect the issue is one or both of two things. 1) it may be that Volumio isn’t sharing the SSD to the network in a way that Macs can properly deal with.

And/or 2) mounting the drive via the network apparently causes Volumio to immediately and continuously rescan the drive, like it does when you click update or rescan in the Volumio UI (as evidenced by the little rotating circular pair of arrows next to ‘Music Library’ in the UI). So it may be that this makes Volumio think, or tell connected Macs, something like ‘the drive is busy right now, don’t change anything’.

Win10 here. I use WinSCP as the file transfer agent to keep my Volumio drive synced with my local HDD. In my mind, it’s a great compromise for keeping everything lined up. I thought about having my Pi sync directly to my Google Drive account, but WinSCP avoids my having to figure out setting up Google Drive in Debian.

I hadn’t really thought about trying to sync using Win10 as the mediator. I just can’t see Win10 playing nicely with a Linux environment. WinSCP doesn’t care. Don’t know if there’s a Mac version, but there’s certainly a Mac equivalent.

To run it, I just have to log into the Pi. Easy as …

I believe I’ve solved the issue, at least for now.

I managed to use a windows machine, and accessed the drive across the network.

Most ways of viewing/altering the relevant permissions resulted in ‘access denied’ type messages. But right clicking on each subfolder at the level below MUSICUSB (in my case I have different folders for lossy, lossless, my own music and so on) and changing the permissions as mentioned above did work. It was laborious and took a while, but I think it worked.

Well, it appeared not to work - the attempt yielded numerous messages saying access was denied to various files. But I realised that the files mentioned weren’t the actual music files themselves - they were hidden files prefixed with underscores and suchlike. I don’t know where they came from. But clicking ‘ignore all’ got past this, and windows was able to then successfully change the relevant permissions for the files that matter. And after I’d been through all the folders and done this for each one, I then successfully managed to write a new folder to the disc from my Mac.

I should point out that I have been able to access the same drive in a similar way when I used other software (Roon). And with the drive connected directly to the Mac or Windows computer, there were no issues at all. So from that, and the fact that there seem to have been numerous people who’ve encountered similar issues on this forum, it definitely looks like the issue is with how Volumio shares drives to the network. It seems to be blocking write permission for files which shouldn’t have that permission blocked according to the settings the user can see. And having to use a windows machine isn’t really a fix.

But, at least for now, it appears to be working.

No, it appears I spoke too soon.

Now trying to add a folder of music to the USB drive, and no matter what I do, my Mac reports that the drive is full.

It isn’t, there’s plenty of space on it.

Yet it works if I move files manually one at a time, or, apparently, up to six at a time (so approx 200MB of lossless audio), it works. Any more files at once and no, it says there no space. But up to six tracks, it’s ok.

So at least I did what I wanted in the end, but this is just plain weird and arbitrary behaviour, and clearly not working as it is supposed to.

I have made a shortcut to the Pi’s USB drive on the Win10 desktop


This opens the USB drive as a folder so I can drop new music into there.
BUT like you say, if I try to copy a lot of tracks at once I get the ‘disk full’ warning. Copying less at a time works. Strange.

If you have a saved shortcut, does Volumio start a library update when you start windows (ie does the little circular spinning pair of arrows appear next to music library)?

On Mac, I use a ‘connect to server’ command to open the USB drive folder. So at least notionally there’s no connection made from the computer to the Pi/USB drive until I tell the Mac to make one.

Connecting this way seems to trigger Volumio to start an update/rescan process, even before I try to actually transfer any data, which I had thought might be somehow involved in the problem.

But if on Windows connecting to the USB drive automatically doesn’t trigger a rescan, but the same problem manifests, then the rescanning probably isn’t a cause for the issues.


Looks like I’m resurrecting old topic but I got the same issue @Dr_Endarken have you found a solution?

It’s been a while, and although this now works OK for me, I’m afraid I don’t recall what specific thing did the trick.

There have been several MacOS and Volumio updates in the meantime which probably helped, but the biggest other kind of change I made was unplugging the network cable and running via WiFi. That shouldn’t have made a difference, as I have various other devices working perfectly well via the same Ethernet switch, but it did.

So if you’re still having the problem with all software up to date and you’re using Ethernet, I’d suggest trying WiFi instead. But other than that, I’m afraid all I can do is wish you luck!