Accessing USB drive remotely

I run volumio on a pi4 with a hifiberry dac pro and a USB harddrive with my music on. Now I’m new to this and on another thread pwstereo told me that I don’t need to disconnect my hdd from my pi to add music to my library. So I go in my file explorer to my volumio: Knipsel.PNG
and if I open the USB folder I find my harddrive and an empty folder named EFI (no idea what this folder is). If I open my hardrive folder I get this:
Now the only folder I put there is the Flac folder. I want to remove the bin, because it contains some old tracks with wrong tagging, but I cant delete it: Knipsel3.PNG
It says that I need permission by Unix User\root. I also can’t add any new music to my Flac folder.

Does anybody know what I can do to fix this, so I can edit my harddrive folders remotly from my PC, instead of unplugging my drive from my pi and plugging it into my pc?

Your USB HDD seems to have a lot of Windows debris on there. Can you reformat as fat32 or ntfs?

I already did this, it was fine for some time, but when I tried to access it remotly the windows folders were back. I’ll try reformatting again and let you know.
EDIT: Last time I reformatted to exfat, i’ll try ntfs now

I think the problem is that Windows will recreate such folder each time you manipulate file from it.(not sure though). One way could be to exclude scanning this folder in Volumio.

How can you exclude a folder from scanning?

I reformatted the drive to ntfs and the clutter folders ar still there, but now I can edit the folders remotely and delete them

And also, I asked this on my other thread abot organising my library for volumio, but no mod/dev answered there: Is there a way to add pictures for the artists, or where does the system get them?

I can help with the insisting auto-recreating recycle bin. Connect the USB drive to a Windows computer and right click the Recycle bin icon in your desktop, then click Properties.

Select your USB drive from the list and check the second option (“don’t move…”) as per the screenshot. Then click Apply and you’re done.
(If the recycle bin is still showing in the USB drive, delete it manually by enabling “show hidden files” in the View menu from the file explorer in Windows).

ah thx for this