[2.917 on Rpi2] Cannot access web UI

Volumio 2.917 on RPi2 repeatedly fails to open webUI. There’s no error, no message. Just an empty white screen.

When it happens, SSH usually (not always!) also fails (“connection closed”) BUT the backend still work - I can control it via Home Assistant integration, Airplay or the Rigelian app for Mac/iOS. This is after repeated factory resets and complete reinstalls (format SD card, flash with Etcher). Other devices (Rpi4 with Kodi, Rpi4 with Home Assistant, Synology NAS, many smart devices with Tasmota or ESPHome…) work fine. Tried different cards. Content blockers are disabled.

Tried to access the log when I managed to SSH into it, but it gave me some “input/output error”. Apologize for not writing that one down.

Not even powercycling always brings the webUI back. The system is completely borked. Also, on new install, I can’t ever connect to the Volumio hotspot from any Apple device. I have to do the first-run with ethernet.

We really need to see system logs to find out what is going on here. If ssh is working then:

there is a way to get logs also from SSH, so please do this:

  • Enable SSH
  • Leave it going, until the UI is unresponsive
  • Connect via SSH and launch this command:
node /volumio/logsubmit.js

After you do it, wait a little, you should receive something like:


Paste this link here please.

As we speak, I’m only able to access Volumio webUI from ethernet-connected Mac. webUI is not accessible from any wifi device, even this Mac when I yank the ethernet cable from it so only the wifi is active.

Over wifi, only empty page is displayed. I CAN, however, Airplay to it wirelessly from iPhone, I can use Spotify Connect, the Mac/iOS app Rigelian can control it, and so can Home Assistant.

Volumio 2.917 running on a Rpi2 with a wifi adapter. I was not able to connect to the hotspot at all, I had to do it via ethernet and run the first-time setup wired. Now it’s running purely wireless.

Here’s the log. Only the two Spotify plugins from the official Volumio store are installed.

Curious to what you’ll find in the log… Thanks.

1 Like

Two hours later, I can access the webUI via wireless… I’m clueless.

You have big problems with your audio collection. From 17:28 to 20:42 your RPi is attempting to update your music library (resource intensive, and may well affect the UI on this lower powered Pi), and is finding many mp3 files that ‘mpd/ffmpeg’ are not happy with. These could be corrupted, malformed, or just not considered valid. I can’t see any errors after 20:42, which would prevent the UI being accessed … this would explain your “Two hours later” observation.

So, you will probably find things ok unitl the next update/rescan, but, of course, you will not be able to play a significant proportion of your library.

That’s weird, I haven’t noticed any issue with any other music player, can you point to a reference file that’s deemed as invalid so I can check it out? i think I’d notice if I had swathes of music not playing. Thanks.

It could be a bug in the ffmpeg library. I would suggest trying Volumio 3 Beta.

Probably. I’m trying random songs with various players on Mac and also the Moode Audio system running on the same Pi 2, there is zero issues. It has to be a Volumio bug.

Update for anyone running into similar issues: running Moode Audio on the same Pi, same SD card, same audio files. Zero issues. Week of uptime. Much faster. I’m sorry, my audio files are not corrupted, the software is just buggy.

Glad you’re sorted. Perhaps it is a difference of mpd or ffmpeg version (Moode’s mpd is later)

Edit: your comments have made me delve into this a bit more … I’ll be back.

1 Like