101 Direct Volumio GUI Raspberry Pi + 3.5 LCD TouchScreen


I recently purchased a RPi 2 + 3.5 LCD and case for 46$ s&h included… Couldn’t resist…


My goal is to have an all in one Volumio system, with touchscreen allowing me to operate basic Volumio functions.

Here is the result !!

Ressource : http://www.waveshare.com/wiki/3.5inch_RPi_LCD_(A)#Software for important informations into the FAQ. Don’t use the driver on this page if you bought the very same hardware as mine.

1) Install Volumio on the microsd, use all the available space extending the filesystem. You need at least a 2GB sdcard.
A little reminder to use all available microsd space.

First you have to use fdisk to resize the partition to fill the whole SD card. You can do this by doing:

fdisk /dev/mmcblk0

Press “p” to show the current partitions and note down the details of the main one that RuneOS is on.
Delete it, pressing “d” and choosing the relevant partition number. (Number “3” for me).
Press “n” to make a new partition, and “p” to select a primary partition. Enter the same start block that you wrote down above, and allow it to use the default end block (the last block available on the device).
Press “t” and enter the value “82” to mark it as a Linux partition.
Press “w” to write changes and exit. You may have to reboot after this for changes to be registered. This has resized the partition, but not yet the filesystem.


Next, use the resize2fs command in this way:

resize2fs /dev/mmcblk0p3 (“3” for my setup)
This will resize the filesystem to fill the whole partition, and you will have a lot more space available for stuff.

2) update RPi :

rpi-update reboot <-- several minutes, then reboot.

3) Setup display on the 3.5" LCD as primary display

apt-get update apt-get install lightdm <-- several minutes.

raspi-config -> Check the configuration: Enable Boot to Desktop/Scratch -> GUI
4) Install driver :

cd /root wget http://osoyoo.com/wp-content/uploads/samplecode/raspberry_35_inch_ts.rar tar -zxvf raspberry_35_inch_ts.rar tar -zxvf LCD-show.tar.gz (you get a ready to use raspbian distro with drivers and the drivers !!)

tar xvf LCD-show.tar.gz (the drivers)

cd LCD-show ./LCD35_v1 <-- Should take several minutes before automatic reboot. DON’T EVER REBOOT when shuting down process started, the reboot last for minutes too.

Miracle the RPi boot with display on the Touch LCD screen and display a GUI login !!

5 Install LXDE

apt-get install lxde

Sometime you get a GTK cannot open display error… just :

apt-get install xinit

Test launching startx
You may see the GUI appear. On next reboot, LXDE will automatically start logged as Pi as we choose “GUI” in raspi-config.

6 Display Volumio WebUI
To start GUI and midori on Volumio GUI automatically at boot.

[code]nano ~/.config/lxsession/LXDE/autostart
Comment out everything using a ‘#’ at the start of each line and then add the following lines

Auto run the browser

@xset s off
@xset -dpms
@xset s noblank
@midori -e Fullscreen -a[/code]

Next step :
Analyze performance impact on Volumio.

Your comments are welcome


I’ve got Waveshare 4 inch, the drivers from their site are not working indeed.
Where did you get the drivers from?

Look at chapter “4”.

It seems very interesting. I’m looking forward to see test about performance impact.

As far as I tested no impact on listening (mp3 320kbp mainly), on the RPi 2
Anyway to say the truth, Volumio GUI isn’t adapted to this small screen and resolution.

I hop Volumio 2 will come with a minimalist interface…

Well, chapter 4 has info about 3.5 inch waveshare. I tried a dummy approach to simply install these drivers, but no luck.
If I’d knew what’s the difference between these files and those provided by Waveshare, maybe I could make them work.
I think it could also be benefitial to run the browser as a window manager. Volumio has an ability to set the network and switch itself off from the web UI.

You may have noticed that I use a 3.5 screen, and the driver directories names start with 35… 40… if my memory is good…

Did you use corresponding driver ? 35 for me, 40 for you I guess…

I have a Pi TFT 2.8’ can you help me install my tft to works with volumio?

thanks :stuck_out_tongue:


root@airaudio:~# tar -zxvf LCD-show.tar.gz tar (child): LCD-show.tar.gz: Cannot open: No such file or directory tar (child): Error is not recoverable: exiting now tar: Child returned status 2 tar: Error is not recoverable: exiting now root@airaudio:~# tar (child): LCD-show.tar.gz: Cannot open: No such file or directory bash: syntax error near unexpected token `child' root@airaudio:~# tar (child): Error is not recoverable: exiting now bash: syntax error near unexpected token `child' root@airaudio:~# tar: Child returned status 2 bash: tar:: command not found root@airaudio:~# tar: Error is not recoverable: exiting now bash: tar:: command not found

possibility give img installed?

Seeing the outpout, the .tar file doesn’t exist.

Sorry for the image but I reuse the LCD for another project.

Just triplecheck the file you downloaded.

i have been having ago at following your instructions for some time now and had no success , after installing the drivers i get this error (see picture ) as im a complete noob to raspberry pi i have no idea what im doing wrong , do you have any suggestions?


I don’t think you got the EXACT same LCD panel,

Are you using the correponding driver of your panel ?


hey ,
im using this panel : amazon.co.uk/gp/product/B00Y … ge_o00_s00

and i installed this driver :http://www.waveshare.com/wiki/5inch_HDMI_LCD

The driver i sed was called ; LCD-show-151020.tar.gz for 2015-09-24-raspbian-jessie

i installed by doing

wget waveshare.com/w/upload/9/9d/ … 020.tar.gz

tar -zxvf LCD-show-151020.tar.gz

cd /LCD-show

and it then reboots and i receive the error seen in the picture before.


1 Like

Man I guess you aren’t using the driver of your lcd panel…

You have to get it. Ask the vendor, or use google to get it using exact reference of your board.


Hey ,
it cam with a cd but im not sure how to get the driver off that to the raspberry pi as im not two confident with linux any suggestions on how to ??

1 Like

To instal a driver you generally must follow the readme present in the CD.

You got to google with your exact reference + raspberry I guess you’ll find the solution.

hey , i finally got the drivers working (i think ) but im having problems now with the fdsik :

in the instructions you mention you used partition three that contained RuneOS but mine only has W95 FAT32 and Linux ? which one of those partition should i delete to make a new version of to extend



nice for the driver.
You got the same sdcard layout partition so same than my example…

Dear Yakelkun,

I’d like to express my experiences using partly your description.
For now I had two major obstacles and put some effort in getting around these and I don’t want this to be unexpressed here.

My Setup:

  • Raspberry Pi 2
  • Waveshare 5’’ screen (using HDMI and GPIO)
  • Volumio 1.55 (08/02/2016) (based on Debian Jessie!)

I set up Volumio and installed the Screen using your description and these drivers from the waveshare page.
There I got the first error!
Kernel panic - unable to mount root fs on unknown block
RasPi didn’t start up anymore.
I tried different things, googled a lot until I found out that due to the repartitioning the root partition was on mmcblk0p3 but cmdline.txt (the new one written while the drivers were installed) mentiones mmcblkop2.

SOLUTION: Put your sd card in a pc, and change the cmdline.txt in the boot partition. There is a part with root=/dev/mmcblk0p2, just change it to 3 and it should work.
I guess another solution, and the more sustainable one would be to move the root fs to partition 2 again. Will try that out later.

After that was done the next problem was at hand.
If you install startx on Debian Jessie, it will not start on this type of screen. The error: No screens found If you look into the suggested log file for more info, you will find that fbturbo could not be loaded. That is because fbturbo is just not installed in Jessie!
There are descriptions to compile fbturbo on your own (for examplehere)

After compiling fbturbo - voila - it worked. Startx started.

That’s where I am now and I try to update as soon as I have more.

Thanks for your description motivating me to approach this!


please have a look at my previous post.

You need to change the cmdline.txt in the boot partition.