X86 Hardware issues (WiFi, DAC, Disks, Boot etc.)

Had a quick look at your log, quite a number of acpi errors, meaning parts of hardware components were not recognized/ initialised and the Xorg display manager failed to start. You only have a terminal interface at the moment. I will have a closer look tomorrow, but as said, there is not much I can do.
It would be extremely interesting to know whether the beta version, as pointed to in my previous post, makes a difference.

@wheaten: could you please move this conversation to the proper place? Thanks.



The S10-3 has an Intel GMA3150 graphics interface which requires OpenGL 2.1 or higher.
Same with Samsung Netbook NC210.

With Volumio 3 this is not supported anymore and I can’t think of a workaround for you either, sorry.

Thanks for checking gkkpch, I will try the beta version if it works. Appreciate your help.

Understanding the issue now, I’m sure the beta won’t work either.

Hello, I’m new here.

I have Intel NUC NUC8I5BEH with nvme drive inside (Windows 10, Kodi and jriver) and 4TB NTFS formated SSD drive (with my music in FLAC files). SSD drive with my music have label iSSD and this solved problem that now Volumio can see music on this drive.

First I downloaded Volumio-3.512-2023-06-25-x86_amd64. Then used rufus to create bootable USB drive (16GB)

Before I connected this bootable USB drive with Volumio on it I disabled SATA and m2 port in my NUC bios. Just in case as I didn’t wanted to get in trouble when installing Volumio.

After this was done I started my Intel NUC from this USB drive with Volumio image on it. No problem with this.

I could use Volumio and everything was fine.

Then I wanted to install it on my external USB C Orico enclosure with Samsung 256GB nvme drive.

Everything was OK until restart. Then I got error.

So… I was thinking that maybe Volumiobuster will make it. Volumiobuster-3.538-2023-08-07-x86_amd64

Unfortunately I did everything like previous try and got the same error. Please see the picture.

Then I made few more experiments.

I tried to install it on 32GB micro SD card. Got the same error.

I tried to install it on 128GB SSD drive in Sabrent case connected via USB and the same error.

Then I decided to turn on SATA port and m2 slot in my NUC bios. Got the same error.

At the end I used my USB pendrive which have Volumio installed and tried to clone it to my USB C enclosure with Samsung 256GB nvme drive without changing partitions sizes. 1 to 1 copy.
Of course I got the same error.

So… at this moment I give up. But I would be very happy to have Volumio installed not on USB pendrive but on my USB C nvme drive.

So atm the only way for me to use Volumio is to have it on 16GB USB stick. Can’t install it on internal nvme drive or internal SSD drive because they have Windows operating system and my music.

I would prefer to have Volumio installed it on USB C 256GB nvme drive.

I didn’t had any problems to install Libreelec (light version of Linux with Kodi) on similar USB C nvme drive.

I just have problem to install Volumio on it.

Could someone please tell me where the problem can be ???

Thanks in advance.

The nvme driver module is in the initramfs, so there must be another module missing causing the drive not being recognized during the init phase and cannot be booted from successfully.
You are the first person to encounter this issue, sorry.
Could you tell me which USB C 256GB nvme drive you have?
Can you boot Volumio from usb, connect the usb-c drive and do

ls -l /dev/nvme*
sudo lsmod

from the commandline?

1 Like

@wheaten could you move this one to the X86 issues thread please?

First I would like to say thank you for answering me and offering help.

I have no problem to be first person with this problem. Someone always have to be first :wink:

I did what you asked me to do. Here are the results.

  1. I take the picture of boot options.

The nvme drive is: Samsung SSD 960 EVO 250GB

Is installed in enclosure Orico NVMe - 10Gbps from this link. Looks like enclosure is using RTL9210 chipset.

ORICO M2 SSD Case NVMe USB Type C Gen2 10Gbps PCIe SSD Case M2 SATA NGFF 5Gbps M.2 NVME Enclosure Disk Box M.2 SSD Case - AliExpress

  1. lsusb

  1. ls -l /dev/nvme*

  1. sudo lsmod

the last one was bit problematic because when I entered password I got very long list of devices and I have no idea how to scroll this list to take pictures

But please remember that I got the same error when trying to start Volumio for micro SD card and regular (not USB C) SSD USB drive.

Booting from an SD card is very rare on an x86 device, so I have not done anything to prepare that.
I will have a look at your data.
The Orica device is available here from Amazon and as I intended to buy a usb-c external drive anyway (not for Volumio), I’ll get one with your specs and test with it before giving it its intented destination.

Strange, this is what I use now and want to replace. It tested it with Volumio and it works fine.

Thanks for help.

So far I have to keep Volumio on regular USB pendrive and it is working.

But I don’t like the idea of keeping OS on pendrive. I preffer external SSD or nvme drive which I have many to use.

I noticed that I’m not the only one who have similar problem with boot from USB.

But I’m happy with sound quality a lot.

I use jriver on Windows 10 with Topping D10s DAC and this is the best quality but only because of dedicated drivers for the DAC.

In Linux category Volumio is the best so far. Much better than Kodi (Libreelec little Linux edition).

I’m curious about D10s driver in Volumio. Because it is the best implementation of this DAC in any Linux system.

Could you please tell me bit more about DAC drivers on Volumio? Where can I read more about it?

What is causing Volumio which is based on Linux to sound much better than other Linux systems?

So far only Windows with D10s dedicated drivers with ASIO was offering the best sound. Now with Volumio I see that Linux based system can also sound great.

Unlike WIndows, Linux and Mac do not need specific drivers for DAC hardware as they have a generic sound driver (with some additional dac-specific quirks. e.g. for DSD compatibility).
Topping D10S is known to be working fine, incl. DSD direct capabilities.

1 Like

Thank you for answer. yes I know that.

But I’m very surprised in positive way that Volumio is Linux based but sound quality is very good.

I think that the devil is hidden in details.

Finally closed this Orico usb to nvme adapter issue, caused by missing UAS (usb attached sata) support in our initramfs.
There was no relation with nvme at all, just a missing usb storage module in initramfs.
Thanks @JMZ for reporting this issue, would not have found it otherwise.

To be released with the next version of Volumio 3, with current and upcoming 6.1 kernel.


Thank you.

Little present, full blown Volumio beta version:
You can’t report on it other then the x86 beta thread.
You can’t update to the final version.

Continue to use the existing image with ausb key or switch to a full-blown beta with Orico, your choise.

Not sure about when the switch takes place, not my call.

Cheers - Gé

Case now closed for me

1 Like