X86 Hardware issues (Graphics, WiFi, Onboard Sound, external DACs, Disks, BIOS/UEFI Boot problems etc.)

Solved, problem was in antenne connector but I connected Volumio Optiplex by wire for better transfer.

I decided to boot from USB and use shared local files. I have problem with UPNP servers ( not showing metadata of song, I found solvation with search engine :slight_smile: ) and before I will configure samba server I shared USB disk from Volumio Pi as a NAS for Volumio Optiplex. Works perfectly.

Volumio on Atom230 is very stable, boot few minutes but after start works smooth without any problems.

1 Like

I think this might get mixed up. My reply was for the futro s740 and not the dell. Overall my experience is that thin clients can be a very good solution, but of course it depends on the model.

The futro s740 has a 4 core celeron J4105 which is quite powerful for just music playback.

I am currently running volumio on a futro s920, which has an even less powerful AMD GX-415GA SOC, but has a pcie slot, where i can use a quite good quality pcie sound card (thanks @gkkpch for helping with this asus card to get it to work). However, the s920 thin client is doing very well regards to performance.

As there are too many different models of thin clients, the volumio team cannot test them all and not ensure compatibility for each of them. Linux itself can be a trouble when it comes to uefi boot… I remember very well that just some years ago some intel atom cpu based Laptops had still big trouble to boot Linux via uefi, while they worked well with windows. The issue was not with the cpu but with the bios or chipset.

Im fact, linux is great overall but is always a bit behind the drivers and wide hardware support when it comes to new standards. As linux is open source, while windows is commercial, the driver support is mostly concentrated on windows first and Linux comes with a delay.

The big benefit however is that Linux supports very well lot of old hardware where Windows kicks it out.

So for the futro s740… It would be very time consuming to find a solution. Maybe the easier way is to just use another thin client model, or re-try once volumio uses debian 11 or 12.

Debian 11 or 12 won’t make a difference, it is the kernel and firmware which count.
Newer kernels and firmware seldom (if ever) do anything for old hardware, they focus on existing and new.
Volumio will have kernel 6.6 LTS and the latest firmware with the upcoming version, but the Futro won’t profit from it in any way.

Ok looks like I will have to buy different hardware, its a shame because performance is great when it works and only draws 4w when running and only cost £40!!

Thanks for your help, I still love Volumio :slight_smile:


Or you just boot it from an usb stick or attach the sata disk via usb case. If i remember correctly, for some strange reason the boot from usb worked on the futro.

You could then use the internal m2 sata just for your music files.

maybe this workaround is worth a try.

On my Pc Windows 11 , after upgraded my volumio at 3th version i’ve had some troubles and i don’t like it.
I would downgrade at the last version of the 2th edition before the 3th (for windows)
Someone has a link?

I don’t know what you are talking about.
Volumio is an OS, not an application for windows.
There is nothing for windows.
But you can install it on your computer…

1 Like

You’re right, I meant the old version for PC and not for raspberry. Sorry

V2 support & maintenance ceased years ago.
Instead of asking for an old unsupported version, you would do yourself a bigger favor by explaining the issue, and when possible, add logfiles as explained here.

And add any other info requested from this post

I’ve installed Volumio 3.569 on my X86 pc. I bouth a Waveshare 8.8" screen no touch 480*1920 but
after connecting waveshare 8.8" to my pc via hdmi, no display plugin found in the user interface menu, so it’s impossible to use mymoniotr that remains black.
The screen normally starts under Windows 11, and during staarting of volumio the login screen appears…after i see only the backlight and no images.
Any idea,can someone help me?

there is no need for the plugin. The x86 image has already the needed drivers installed. Please enable HDMI under system.

ok, but in Sytem the Hdmi video output option is already enabled, but no image was on the screen.
if i turn off volumio,in the scrren with the word “volumio” normally appears on my screen…
When i turn on volumio on the screen remain only the initial screen of volumio login
and the gui is only possible by App Volumio on my phone or by webui on the browser…
help me…i don’t understand

I have a Wyse 3040 which was working fine until recently.
I could not remotely connect. I pluged it in a monitor at it seems it lost network. Both ethernet and wifi.
lspci can see the devices. It is very weird. I cannot post logs obviously.
lshw shows network as UNCLAIMED
inxi -Fxxxz shows the network adapter correctly

kernel version 5.10.188-volumio

any ideas? corrupted installation? should I try to reinstall?

as far as I know, there is no wifi on Dell Wyse 3040.
Did you try an update before this issue?

The wifi is a USB dongle which was working fine.
I believe I did try an update before that.

maybe a factory reset from command line could help?

yes, you can try

volumio updater factory

or before if you’re lucky

volumio updater testmode
volumio updater forceupdate

factory reset did not help. I think I have to reinstall.

I booted from a fresh USB all works fine… so it is not hardware issue… It is really weird.

volumio 3.569 installed on x86 box (dell wyse 5010) does not shut down.
not in the web ui or in terminal sudo shutdown -h now is working.
it stops at “target reached power-off” and the computer stucks there (only can be turned of with pushing power button 10 secs).

during shutdown there is also an annoying conflict with a stop job running for closing smb shares (1min30sec), which seems to be because wifi is already shut down when volumio tries to unmount smb.

this has nothing to do with the shutdown problem, which persists even when I unmount smb in terminal before sudo shutdown -h now.

any advice is apreciated i am dealing with this now for three days and can get it fixed.

Sorry for my bad english
thanks in advance

I moved your post to a more suitable place.
Please read the first post in this thread, as it is extremely difficult to respond otherwise. There are zillions of x86 configurations in the field, unlike an RPi or whatever other ARM board.