X86 Hardware issues (Graphics, WiFi, Onboard Sound, external DACs, Disks, BIOS/UEFI Boot problems etc.)

Not working on wireless card Intel Centrino 62230ANHMW / Sony Vaio PCG-4121L.
Says ”Choose a network…” but does not show a list of available to choose from.
I can send the three reports by connecting it to the wired network.

Surprised, the firmware is present and loaded

Jan 09 09:46:23 volumio kernel: iwlwifi 0000:02:00.0: loaded firmware version 6000g2b-6.ucode op_mode iwldvm

It gets an IP address:

Jan 09 09:46:35 volumio avahi-daemon[489]: New relevant interface wlan0.IPv4 for mDNS.
Jan 09 09:46:35 volumio avahi-daemon[489]: Registering new address record for on wlan0.IPv4.

and then looses it

Jan 09 09:46:46 volumio dhcpcd[556]: wlan0: using IPv4LL address
Jan 09 09:46:46 volumio avahi-daemon[489]: Registering new address record for on wlan0.IPv4.

Try using eth, then disable the hotspot and see if wifi works in normal mode. It could be incompatible with Volumio’s hostapd (scanning not supported while in ap-mode).
Also try and create a file /etc/modules/iwlwifi.conf with the following contents:

options iwlwifi 11n_disable=1

Otherwise no idea why this happens and to be honest, not really worth investing a lot of time for. The notebook is >10 years old…

Try replacing the wireless card with another Intel card, it is a removable module, probably accessable for a bottom hatch.

Or, remove it and use a usb dongle, like the TP-Link T3U or T3U plus.

I disabled the hotspot and 3.396 worked normal. Thank you!

Disabled the hotspot too on 6.1.1 and now it s working fine on the Intel Centrino 62230ANHMW / Sony Vaio PCG-4121L.

Hotspot could be failing only when using 5Ghz, but I did not look into that. Good to know it works.

Am setting up a small sized X86 unit here and am thinking maybe my TL-WN725N, super common WiFi dongle just isn’t supported.

I have an error “ Error while restarting wireless: Error:

Command failed: sudo /bin/systemctl restart wireless.service Job for wireless.service failed because the control process exited with error code.

See “systemcti status wireless.service” and “journalcti -xe” for details.”

Does anyone know either;

Which usb dongle will work with 3.396?

Or which older version do I need to use in order to use my existing WiFi dongle?

Hi Janky,

Please provide the info as request in the start of this topic, so we can see if we can make it work.

That is possible, this dongle has different hardware revisions, that is why a log is absolutely necessary. Please also look on the dongle and try to locate the hw. revision number (v?)

info: CoreCommandRouter::executeOnPlugin: system , getHwuuid  info: CoreCommandRouter::volumioGetState info: CoreCommandRouter::volumioGetQueue info: CoreStateMachine::getQueue info: CorePlayQueue::getQueue info: CoreCommandRouter::executeOnPlugin: system , getHwuuid info: CALLMETHOD: system_controller system enableLiveLog true info: CoreCommandRouter::executeOnPlugin: system , enableLiveLog info: Launching a new LiveLog session  info: CoreCommandRouter::volumioGetState info: CoreCommandRouter::executeOnPlugin: wizard , getShowWizard info: CoreCommandRouter::executeOnPlugin: system , getShowWizard info: CoreCommandRouter::executeOnPlugin: system , getSystemInfo info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , getThisDevice info: Discovery: Getting this device information info: CoreCommandRouter::volumioGetState info: CoreCommandRouter::executeOnPlugin: network , getCachedIPAddresses  info: CoreCommandRouter::volumioGetState info: CoreCommandRouter::volumioGetQueue info: CoreStateMachine::getQueue info: CorePlayQueue::getQueue info: CoreCommandRouter::executeOnPlugin: system , getHwuuid


I hope this can reveal something useful, many thanks for the feedback btw.

1 Like


Did you read my reply to your post, please follow the instructions under reporting, in the start of this topic. Just random copy some lines is not getting you closer to a solution.

Just for your understanding, we don’t have crystal balls and/or tarot cards, we do need this information to help you.


TL-Link T3U works perfectly.

Difficult, TL-WN725N has several revisions. TP-Link is known for changing to different chipsets, they keep the dongle name, but give it a new revision number :man_shrugging:
We need the bootlog, to be created from the dev page, see OP.

My apologies that my entire log hadn’t displayed on this forum using a copy/paste.

My time is worth money, as I am sure yours is as well. I have kids and choose to not ignore my family by working on things like this for hours on end.

Now if someone had a known wifi solution, for 3.396/X86, I wouldn’t be wasting any more of anyone’s time on this $10 wifi dongle. That information would be useful, and likely far more efficient.

If not, I will probably choose another solution, life is too short.

I’ve given you the solution just one post above your latest, but you’re free to ignore it.
My time is not valued in money, there are more important things in life than worrying about that :grinning:

1 Like

Many thanks for your help, really like the Volumio platform.

Sorry, is early here…

I am extremely disappointed with Volumio. When I started using it, everything was absolutely perfect, about two years ago. But over time, each update gets worse. I use it with a miniPC, not RaspBerry. Now what totally pissed me off is the wifi anomaly. I cannot use the Volume with a LAN cable because the router is in the next room. But so far it hasn’t been necessary. I turned on the Volume and the wifi connected automatically. So far. However, since the latest update, I’m just struggling. When I turn on the streamer, there is no connection, but I have to bring a monitor there, connect with HDMI, and then manually connect to the wifi. When connected. But sometimes it doesn’t connect, or when it does, the NET is so slow that TIDAL only stutters. If I connect to TIDAL with something else, the client program, it works without problems, but not with Volumio. Then Volumió thinks for a moment, and the normal Wi-Fi signal arrives, it works fine, then suddenly the speed drops again. It will be fine again. In the meantime, measuring the wifi speed with another machine, everything is fine. Sometimes there is no problem for days if I don’t turn it off, then it goes wrong again. I tried with a different wifi key, but it’s the same. If I turn it off and turn it on the next day, the Wi-Fi problem starts all over again. When I updated, it was able to update in 18 hours. I tried reinstalling, no results. So I just congratulate Volumio because they were able to make a lot of crap out of a great system, I mean in my case. Again: I’m not using it with a RaspBerryPi, but with a minipc. I am a subscriber, but I didn’t subscribe to this, but to a working system!!!


Sorry to hear things are not going well. Please see the first post in this topic and provide the details mention under reporting.
It might be possible that something is wrong with the driver, signal quality, WiFi antenna, but we need to have more info.

Greetings sage guru’s of Volumio!

I have a similar issue to the last. I purchased a HP 620 thin client that was supposed to have a wifi card (but it doesn’t!!). I have a TP-Link TL-WN725N N150 sitting around (purchase link here).

It has the same failure as Janky describes “Command failed: sudo /bin/systemctl restart wireless.service Job for wireless.service failed because the control process exited with error code.”. It actually see’s my AP but then fails.

I’m on Volumio 3.396, x86/x64 on the HP 620 thin client.

My log file is hosted… (Link removed).

I’m happy to roll up my sleeves and compile a driver for the TP if someone can assist with how-to! Alternately, I could purchase a TP-Link Archer T3U AC1300 locally with some delay and another NZD 65 outlay. Finally, if wifi is denied me, I will get under the house and install a cable solution - you should see it under there though - big spiders everywhere!! :joy:

Any steps to install a x86/x64 driver for TL-WN725N gratefully received.


thanks for the log, it shows you have TL-WN725N revision 2 with an RTL8188EUS chipset.
I already tried to find a driver for it, as there isn’t one supported by the current kernel. I located a DKMS version on the internet: GitHub - aircrack-ng/rtl8188eus: RealTek RTL8188eus WiFi driver with monitor mode & frame injection support.
It will take some time to integrate this into our kernel tree (as was done with a few others) but feel free to compile as a DKMS package and test it.

Hi - thanks for looking into it, the driver search and the advice. I’ll have a bash at it…

Just updating mu post here. I believe I got the DKMS package driver for the TL-WN725N revision 2 built and installed, but it’s still not working actually (same error as before).

Just for the record, this is what I’ve tried. Once I worked out the right cmds, I got success messages all the way along.

sudo apt-get update

sudo apt-get install dkms

git clone https://github.com/aircrack-ng/rtl8188eus

sudo mv /home/volumio/rtl8188eus /usr/src/realtek-rtl8188eus-5.3.9~20221105

sudo dkms add -m realtek-rtl8188eus -v 5.3.9~20221105

Then also installed the header files thus:

git clone https://github.com/volumio/x86-kernel-headers

sudo apt install /home/volumio/x86-kernel-headers/linux-headers-5.10.139-volumio_5.10.139-volumio-1_amd64.deb

And finally:

sudo dkms build -m realtek-rtl8188eus -v 5.3.9~20221105
Building module:
cleaning build area...
'make' -j2 KVER=5.10.139-volumio KSRC=/lib/modules/5.10.139-volumio/build.......................................................
DKMS: build completed.

sudo dkms install -m realtek-rtl8188eus -v 5.3.9~20221105
DKMS: install completed.

sudo dkms status | grep realtek-rtl8188eus
realtek-rtl8188eus, 5.3.9~20221105, 5.10.139-volumio, x86_64: installed

I am probably missing some final step to activate the driver? I don’t fully understand the notes on the Github page about blacklisting another driver, or if they are relevant to Volumio.