Waveshare DSI LCD displays

Hi All

Im so sorry if this is repeated.

I have a pi4 with a 7.9 waveshare display. I have installed the touch drivers as well as changed the userconfig. All i get is a flashing green light on the back. I just cant get it to work. Im using the most current version of volumio (i think april 4 2024).

I also have an 11.9 with the same issue.

Someone pmease help.


Here is the video with mouse pointer switched on. Hope the link will work I didnt figure out how to add it directly from my iPad, sorry.

And there is no reason to have the setting of rotation like now it is only misconfiguration issue, will change it.

THX :+1:

Please try removing the rotation parameter from the overlay and setting the desired amount of rotation from the Touch Display plugin’s config page. Check if touch still has the same issues and report back.

Which display would you prefer to use?

The current version as of today is 3.661.

I would like to use the 7.9 with my pi4 and the 11.9 with my pi5.

I suggest to start with fresh Volumio installations on both devices. Install Touch Display plugin version 3.4.0.

On the Pi 5 add


to “/boot/userconfig.txt” (assuming the display is connected to DSI1).

On the Pi 4 add


to “/boot/userconfig.txt”.

In case you want to rotate the displays try the option on the Touch Display plugin’s config page.


Thank you very much for reply.
I got it working by installing the latest version of Volumio and did not install any driver at all except the latest touch plugin and the lines you posted and it worked out of the box.
Volumio seams to have all the latest driver installed :smile:


Hi, after removing the rotation parameter from userconfig and rebooting Pi, it works great now. Thank you very much.

It works now. My only issue is the touch is not aligned. How would i fix that?

Which display is affected? The 7.9 inch, the 11.9 inch or both?

What Volumio version(s) do you have installed?

Has/have the system(s) been set up from scratch?

Please post the output of

cat /boot/userconfig.txt

and clearly indicate which system it is from.

Hi. I didnt do a fresh install from scratch on the pi4 with the waveshare 7.9. Thats the one with alignment issues.

Im waiting for the dsi cable for the pi5 and ill use the 11.9 for that one. Fresh install most current version on both.

I suggest to start with a fresh installation. Also post the requested output of

cat /boot/userconfig.txt

“… on both”? Previously you wrote that you did not perform a new installation on the Pi 4. :thinking:

By “most current” version, do you mean 3.661?

Sorry about that. The fresh install is on the RPI5 with 11.9 and all works great.

The touch doesn’t work on the RP4 with 7.9. I did not do a fresh install on that one…but I will try that first

I did a fresh install on the PRI4 with the 7.9". The touch still isn’t aligned. I have the screen rotated to 90 degrees.

Add your custom config.txt options to this file, which will be preserved during updates


Touch Display rotation setting below: do not alter


Could you describe how touch is misaligned with the display or maybe better post a video? When recording a video, turn on the mouse pointer, tap the corners of the display and also swipe horizontally and vertically across the display to its full extent.

Is the misalignment present even without rotation?

I tried making a video but it’s too large to post here.

On the RPI4 with the 7.9 and a fresh install… I turned the mouse pointer on and can see that the pointer is appearing below where I am touching. I also tried this with the original alignment at 0 degrees and it’s the same thing.

Does it look the same like in the videos @drhonk posted above?

Yes. Exactly

I have the exact same problem