Waveshare DSI LCD displays

@Darmur test completed with Pi3, display output is working fine but still same issue with touchscreen. It’s definitely an issue with drivers again.I’ve tried all combinations with swapxy, invx and invy, also specifying 0 or 1 value with no luck.

Hello all, I’m in the same situation using the 11.9" DSI screen with an RPi 4 and, after tried every solution I found in this thread, what I’m actually able to obtain is what you can see in those two screenshots:

Volumio is the latest version.
Touch Display is version 3.3.5 (the only one I was able to install without getting an installation error about chromium)
Screen and RPi are powered by two different power supply.
This is what I get if I run the RPi with the standard o.s.:

So RPi, screen and power supply seems to be ok.
Any idea about what’s wrong with my setup?
Thank you in advance.


@AngeloMM please enable test mode and do an OTA update, there is a fixed driver for this display

please be aware that touchscreen does not work yet

@Darmur Dario I really do not how to thank you, your suggestion was absolutely right the screen now works absolutely fine!!!
No problem for the touch not yet working as I can manage Volumio from the smartphone, the big problem was about the display I was almost sure that I did an absolutely wrong purchase but now is fixed thanks to you!!!
Thank you thank you thank you!!!


1 Like

Yes, @Darmur has his moments of thunder :joy:

Hello. I need help. My card died and I had to install Volumio again. I have an 11.9 inch DSI screen. Volumio has been rebuilt and the Touch Display 3.3.5 plug-in is the only one that can be installed.
Please help me run this display. Step by step. He’s scheming and nothing. I have downloaded the waveshare V1 driver.

As first reflash your SD and DON’T install drivers.
When you’ve setup Volumio enable teat and perform an OTA.
Please read through this topic, I believe the solutions is posted by @Darnur 4 posts back.

I recommend to install version 3.3.8 or you will have serious problems if you should update the plugin somewhen - basically, you will have to be prepared to reinstall Volumio then.

If you can’t install newer versions of the plugin than 3.3.5 this indicates that not all software package the plugin requires succeeded to download - just that versions younger than 3.3.5 detect such failures and abort their installation. Most often a network issue is the reason for failing downloads and changing the repository mirror as described here may help.

I think it is very likely that currently there are software packages missing and the plugin can’t work because of that.

Should you continue to have problems please provide infomation on the Volumio version and the Pi model you use.

1 Like

I installed the latest Touch Display plug-in, but the screen is still black? The latest system 3.616 and Touch Display 3.3.8

What is your Pi model?

Please post the output of

cat /boot/userconfig.txt


Touch Display rotation setting below: do not alter




to “/boot/userconfig.txt” and reboot.

The userconfig file looks like this:

Touch Display rotation setting below: do not alter


The screen now displays a blurry image. What else can I do?

Like this? If so, solution should be in post #261.

I don’t understand? Any additional registry entry?

You mean in “/boot/userconfig.txt”? No. At least not at the moment. :wink:

From post #261:

The post suggests to enable test mode for Volumio and update Volumio to a beta/test version with a fixed driver for your display.

P.S. To enable Volumio’s “test mode” go to: http://{yourvolumioaddress}/dev and click the “True” button below “Test Mode”.

The screen started displaying the image, but it is rotated 90 degrees. Setting the orientation in the Touch Display plug-in does not help

Display rotation set on the Touch Display’s config page currently does not work when using “dtoverlay=vc4-kms-…”.

Try modifying dtoverlay=vc4-kms-dsi-waveshare-panel,11_9_inch in “/boot/userconfig.txt” so it reads


and reboot.

This is what the userconfig file should look like after modification?