Volumio on rpi fails to detect SSID

Yep. As I said before, using on-board wifi. It can see a bunch of APs, and not connect to them.

As for hotspot being turned off, this appears to be the nub of the issue; see below.

Yes, that’s why I was at pains to point out that the onboard Wifi on this same Pi works just fine with this AP under Rune Audio, if you recall. The hardware works.

This is the interesting and potentially telling part. Switching off the AP will simply cause wlan0 to vanish completely. This is true whether you boot with the AP off, or you just turn it off and save.

To be completely clear- once you switch the AP off, wlan0 vanishes. This may not be the only problem, but it’s an immediate showstopper that might be worth a look.

I think the forum has eaten my previous reply, telling me that it requires moderator approval. Therefore, I will write the most important part of it again, in case the other post never gets out of moderation limbo :smiley:

When you turn the AP off, wlan0 vanishes. Even if you try to turn wireless on with the AP off, wlan0 is missing.

When I mention AP, I mean Home Wifi AP.
When I talk about Volumio AP mode, I say Hotspot.

So you have your Home Wifi AP set on which channel?
Are your saying that when Volumio Hotspot is set to OFF, wlan0 “is missing”?
I do not understand: how do you see it vanishing?

PS: you need to work from a clean 2.118 image

I am aware of that, thanks.

As I have already said, normally 13, but that’s not particularly relevant, when there’s not even an wlan0 to configure.

Using the magic of my people, handed down between the generations.

No, using any normal means of enumerating network interfaces available- e.g. “ifconfig”, which shows eth0, wlan0 and lo0 when AP is on. As soon as you turn it off, it shows only eth0 and wlan0 present. At this point, you can’t enable Wifi in the Volumio interface either.

Obviously, I am using a freshly flashed 2.118.

This is probably better handled by someone who actually has a Pi 3 available to test, as it’s very easily reproducible, and we won’t have these tiring Chinese whispers, this is starting to feel like uphill work for both of us :wink:

(I’m not overly fussed if it doesn’t work, as I can always run Rune on the Pi 3, which works nicely, and keep Volumio for my old Pi 1 which only has wired ethernet. I assumed people would want to know about this apparently nasty regression, so they could reproduce and fix it. If this isn’t the case, then my bad, sorry for wasting all this time.)

I really sense too many inappropriate sarcasms in your responses: I’m not in for this kind of tone for good-will cooperative work.
Good luck: hopefully you’ll find more relevant people to help you.

Hi @macmpi,

I’ve got a RPI3, and I’m available for investigating if you want to. I’ve got wifi issues also, related to this I think: github.com/volumio/Build/issues/143 But, by chance, my AP may be on channel 4, so that I did not see the issue mentioned in this current forum post: I’ll check tonight.

I read your former posts, but I don’t know if you investigated further since then? What would you like me to test?


Sure, I’m happy to try to help: I’ll recap things here as precisely as I can (because this one is rather complex to debunk and solve remotely), and keep this post updated as it may help others too.

Let’s first make sure we are talking about the exact same wifi issue:
with your Pi3 (or possibly PiZero W) running recent re-imaged 2.118 Volumio2 version (though issue also happened before), stock-Volumio can NOT connect to Home AP wifi IF Home AP wifi is NOT set on Channel#4.
(Please do re-read carefully, and check opposite is also true: Volumio2 connects OK if Home AP is on Channel #4)

That’s the specific issue discussed on this thread: do you confirm this is the particular issue you have?
If not, then please search for other threads about your different wifi issue, and create a specific one if you don’t find convincing results.

If that characterizes the problem you encounter, then the only interim workaround for now is to keep both your Home wifi AP and Volumio Hotspot setting on Channel#4. Eventually you may elect to keep them both on any fixed channel you may set within Volumio Hotspot preference: this should at least give some level of flexibility to find an acceptable match in order to accommodate your particular wifi neighborhood situation…

If you are willing to help resolve this so that it can be fixed for good (thanks!!), can you then please:

  • remove any eventual USB-wifi dongle you may have connected to the Pi.
  • hook an Ethernet cable between your Pi and your Home network gateway (so that we make sure you still get IP network if wifi fails).
  • set your Home wifi AP on other channel than #4 (please check your Home wifi router doc for this: probably can’t help for this)
  • with Volumio2 web interface, keep Volumio Hotspot on channel #4, save, and then turn OFF Volumio2 Hotspot feature & save again
  • with Volumio2 web interface, make sure Wireless is set to ON
  • under SSH, apply the changes mentioned here, just to avoid mixing some other potential issues
  • with Volumio2 web interface, reboot Pi.

Is Pi still NOT connecting to the then-configured Home wifi AP?
Then you may try the suggestion from this post, and report here if it brings any benefit to successfully connect to the Home wifi AP.

Hum, sorry :frowning: I’ve got a RPI3, but channels 4, 5, 6, 7, … are working. Only 12 and 13 are not working, but that’s normal (due to limitations in Japan, Volumio is configured like that)

Not having issues is not a thing to be sorry about! :wink:
Now, can you apply changes from this post, then set hotspot to ON & channel #4, and restart?
Is wifi connection to Home wifi AP still fine, or is the channel limitation issue biting now, if your Home wifi AP is not on Channel #4?

Asking because some recent image change after 2.041 (maybe initially intended for other purpose) may have had an impact on fixing the issue: I’d need to make sure before submitting fix for other matter.
Your help is appreciated.

PS: don’t worry, it is easy to go back, simply reversing the arguments of each of the first 2 commands to restore original files.

Hello: sorry, I didn’t see your post. I’ll so that tomorrow, I’ll have time for that. Best!

Answer is yes, it connects to the Wifi AP (at this stage, I didn’t change anything explained in volumio-rpi-fails-detect-ssid-t5224-10.html#p29621 concerning wifistart.sh, etc…)

By the way, I see that @Ancipital wifi is on channel 13

But Gi said it’s normal that channel 13 doesn’t work (due to limitations in Japan, Volumio is configured like that)

Now I made the changes explained here: volumio-rpi-fails-detect-ssid-t5224-10.html#p29621

And it also connects to Home AP (which is on channel 6 - Mode 20 MHz)

OK, thanks a lot for checking.
So the problem must have been resolved by some other changes between 2.041 and 2.114/8: good, this helps.

PS: Other channel stuff (12/13) is separate, linked to this.

OK, good news.

I understand that this issue is fixed, but I’m still experiencing another connectivity issue, so I opened a new ticket on Github: github.com/volumio/Volumio2/issues/1095


Sorry for necro’ing a thread for 2017 but i’ve just run into the exact same issue with the version of volumio i downloaded today (volumio-2.729-2020-03-18-pi.img.zip). My Wifi AP is in EU and set to auto (which means channel 1 most of the time) and volumio does not show my SSID. I set the router to Ch4 and everyting works fine.

volumio@volumio:~$ cat /bin/wifistart.sh
sudo /sbin/iw dev wlan0 set power_save off

this is the wifistart.sh. It does not make a difference what i set my hotspot settings to, as long as the Wifi is on ch4 volumio can’t see it. A workaround it to create a new AP with my phone (ch# not known), connect volumio to that ssid and then suddenly my home AP appears.

Is there any fix for this except for setting the home AP to ch4?


I am having the same problem. I recently upgrade to 2.729, but experienced the problem with earlier version of 2.x.

If I reflash the SD or upgrade the software, I can add my own network. But if the wifi router is rebooted, my SSID no longer appears in the list and fails to connect.

The only resolution I have found at the moment is to reflash the SD. If I put a vanilla raspian SD card in the pi the wifi connects fine. This is with a Pi Model A and Pi model 3.



Following further testing, I can bring my access point back in the list by adding the line country=GB to the wpa_supplicant.conf file. If the access point details are also in that file, it will reconnect.



Can confirm this is not only happening on Pi3. Same issue here on a Pi zero. Resolved by switching the router to Ch 4.

Version 2.777. Country = AU

Reflashed and connected with a fresh image before I found this thread


This happened to me today. Rpi3 , volumio 2.882, did not see ssid until WAP changed to channel 4. Country = NL.