Volumio on MacBook optical headphone socket not working

Hi everyone just been introduced to volumio. Installed on SD card on 2006 MacBook. Everything seems to work ok but major issue is that the headphone socket which is the audio out and optical does not work with volumio. The socket works fine when running Mac. Os. Has anybody had and solved this issue please.

Before posting, we kindly request you to:

  1. Check for other reports/issues to avoid duplicates!
  2. Add enough information so that the community can help. Things like version number, device, etc…
  3. Try and place you post in the appropriate category/tags of the forum. For example:
    — Do you have a general question? Add the “question” tag
    — Some thing more specific about myVolumio/tidal/qobuz/spotify specific? Add the appropriate tags…

Have you tried one of the images mentioned in [Upcoming Versions]?(Volumio X86/ Debian Buster debugging party (BETA))
Macbooks are not officially supported but seem to work well in some configurations.
We have no plans to add support.

Hi thank you for your reply. I have tried the other images but still not working. I am surprised that MacBooks are not supported. I have posted a question asking for anyone that has successfully installed on a MacBook.

Show me an existing Linux distribution which fully supports a Macbook.
You do not have to be surprised, we never announced full support either.

Most of the linux-driven notebooks could have items not working, for the simple reason that we lack proprietary drivers & firmware for the thousands of vendor-specific components in them.

But when Apple announces support for a “normal” Linux distribution with Intel-based Macbooks, and you can give us the missing driver/firmware parts, we might reconsider :wink:

Note: you could give us the ‘inxi’ or ‘lspci’ information we ask for in the opening post of the thread that held the download link to the beta software, perhaps it helps.
In your case especially important are ‘aplay -l’ and ‘aplay -L’