Volumio no recognizes my external drive

Thanks in advance.

I have tried to use a WD Elements Desktop 4 tb external drive as my main music library for volumio, with no results. Simply, Volumio no recognizes it. As soon as I attach the usb to the raspberry, I hear the mechanical system of the HDD starting, but nothing happens.

Hardware: Raspberry 3 b+/ Micro SD 32GB / WD Elements Desktop 4 TB
Software: Volumio 3.449

I have tried to:
Change the HDD usb cable
Change the USB port
Change the raspberry (same model)
Change the Raspberry AC Adapter
Format the hdd in NTFS and copy only a few flacs

Volumio do recognizes a 128 usb pendrive and a Seagate 10 tb Expansion Desktop Drive.

Honestly, I don’t know What else to do. Could you help me please?

Thanks again in advance.

Edit: forget it: I have tried the last thing I didnt try: changing the sd card of the system. Problem solved!

u got a under voltage with a few errors in the log
how did you connect it all ? with a powered hub or not ?

the drive is detected

`Jun 01 13:56:47 volumio kernel: usb 1-1.3: Product: Elements 25A3
Jun 01 13:56:47 volumio kernel: usb 1-1.3: Manufacturer: Western Digital
Jun 01 13:56:47 volumio kernel: usb 1-1.3: SerialNumber: 575831314442354E45413935
Jun 01 13:56:47 volumio kernel: usb-storage 1-1.3:1.0: USB Mass Storage device detected`

No, directly to the Raspberry ports.

But I dont get it. I mean, I have only two things attached: WD drive, which has its own power supply, and Topping DX3pro+ DAC, which, I think, consumes little power (and it is also self-powered).

Anyway, I have just seen I have been using a AC 2.0 Amp last time for the Rasp. I’ll try with a 3.0 AC

the 3b needs 2.5 amp so it could be that 2.0 amp will come short
a dac will take some current and also a wd hdd will take some both max 500 ma each.
and i advice first to boot the wd hdd before you boot your pi if possible,
i had some wd drives in the past that booted on start of the computer maybe this could be a problem.
pen drives will be auto mounted most of the time.