Volumio hangs after setup & reboot and touch screen plugin

Hi, novice user here.
I’ve built my Pi 4b into a Smarticase with a the Pi 7" touch screen, I,m using the official Pi power supply. Downloaded the Volumio 2.882 image and flashed to the SD 32Gb card. The system boots and I get the command prompt on the Pi screen, I go though the setup using the web UI from my PC. All seems to be ok so I do a restart. Then I load and enable the Touch screen plugin, Pi restarts but gets to a black screen with Volumio in the middle and hangs. I’ve left it for over an hour and no change. I’ve done a power off/on cycle and still the same, also I can’t get the web UI to connect now. I’ve re-flashed the card twice now (just to make sure I’ve not messed up) but same result.

After the first boot make sure to wait long enough so the data partition can fully expand before you proceed with installing further software (e.g. the Touch Display plugin).

Thanks for the reply gvolt. How long would be reasonable? Is there a log that shows the partition has completed (I’m guessing at the terminology)?

This will depend on the Pi model and also the size (and speed) of the SD card. On a Pi4 with a 32GB card 5 minutes would probably be enough, with 10 minutes you should be on the safe side.

You can check the size of the partitions using fdisk:

sudo fdisk /dev/mmcblk0

When you are prompted with “Command (m for help):” enter p.
Then watch out for the size of “/dev/mmcblk0p3”

To quit fdisk type q.

Thanks gvolt
Ok, I’ve tried a new flash of the card and booted the Pi, it loaded and i got the login screen. I waited 15 minutes before opening the web UI, went through the setup (I did not load any plugins), waited another 15 minutes before restarting with the web UI. Alas the same result, a black screen with Volumio in the middle and hangs.
One thing I’ve noticed is the keyboard is ‘jumpy’, when at the login screen I attempted to log in as the volumio user but I had double or triple key stroke on screen (as if I’d held a key down). I tried another keyboard but no difference. After several attempts I gave up.

try 3.xx version instead :stuck_out_tongue: are you burning it with balena etcher or Pi imager?
i have the same setup so ask away… are you using a windows system next to the pi?

// Volumio 3 Buster Beta for RPi

// volumio-plugins/plugins/miscellanea/touch_display at master · volumio/volumio-plugins · GitHub

So, after configuring via web UI (but not installing the plugin) on the subsequent reboot, Volumio did not reach the login screen anymore, right?

Does not sound promising…

If you have a fresh SD card at hand you may try that to rule out a defective SD card.

@gvolt it seems that pi imager will corrupt the bootloader but baleno etcher seems to work oke.

yes, that is correct. I’ve powered down overnight and restarted, I now have the terminal login but the keyboard still creates multi keystrokes. Volumio has not started, I have both terminal windows tty1 and tty2 (ctr+alt+F1 or F2). I’ve ordered another card from the PiHut, in the mean time I will try BalenaEtcher on my current card (Sandisk also from the PiHut)

Thanks for you help.

i think your keyboard doesn’t like the pi try a other keyboard…

I’ve tried both the keyboards I have and in all the Pi usb ports, same problem.

BalenaEtcher has the same result (after the initial boot and setup, hangs on the Volumio screen). In the mean time I’ve flashed a new image of RPi 32-bit using the RPi Imager. Booted the Pi and got to the desktop no problem. The keyboard works as expected (no double keystrokes) and I can get to the terminal window and run fdisk as a sudo. It’s not what I want of coarse as I’m trying to build a music server but it has confirmed the keyboard problem is something to do with Voumio OS.
Looking at this other post it seems like the same issue with reboot?

i think you have to first connect it with a wire… if it’s have the same issue like the 3.079
it switching wifi off if you reboot.

Maybe but image

yeah i had a lot of 2.882 with a lot of problems… try a wire …
i can fix this with my screen you have to connect a wire…

Ethernet cable (wire)?

yess… i have it about that …
if the 2.882 has the same issue as the 3.079 wifi will reset wifi and switches off…

OK, thanks. I’ll try another flash with Volumio and no WiFi.

I just can’t get this to work. I’ve now got three SD cards, I’ve replaced my original 32GB for another and also tried a 16GB card, all new. Non of them boot after the initial install, I can get the UI on my PC and go through the ‘Run first config wizard’. If I leave the UI open at some point it becomes unresponsive, if I reboot I sometimes get the command prompt on the touch screen or the Volumio startup screen but no UI from my PC. I’ve ditched 2.882 and downloaded 3.080 This loaded without a problem and I don’t get the ‘jumpy’ keyboard at the command prompt as mentioned earlier. I can open the UI on my PC and play tracks on my NAS media server.
Now I just need to get the touch display to work. I searched on here to find a way install the plugin manually on 3.080 but can only find old posts for 2.xx
Any pointers please ?

  1. Connect to Volumio via SSH.

  2. Download the plugin package

wget https://github.com/volumio/volumio-plugins/raw/gh-pages/plugins/volumio/armhf/miscellanea/touch_display/touch_display.zip
  1. Create a directory for unzipping the plugin package
mkdir touch_display
  1. Unzip the plugin package to the newly created directory
miniunzip touch_display.zip -d touch_display
  1. Change into the directory with the unzipped files
cd touch_display
  1. Install the plugin
volumio plugin install

When the installation process has finished you will see some finalize message (don’t remember the wording in detail) on the command line. You will probably have to hit “Ctrl+c” to return to the prompt.

  1. Optionally delete the downloaded file and the unzipped files:

rm touch_display.zip
rm -r touch_display

  1. Enable the plugin from the UI as usual.